1

I'd like to install Ubuntu 16.04 on desktop with AMD video card but after successfull install and reboot I got black screen with popap "The system is running in low-graphics mode".

After some investigation I found out that the deal is something about right drivers graphics card.

sudo dpkg -l fglrx fglrx-cre fglrx-amdcccle fglrx fglrx-dev

result: no packages found matching fglrx* but when

sudo apt-get install fglrx

result: Package fglrx i not available, but is reffered to by another package E: Package 'fglrx' has no installation candidates.

Is there a fix to install Ubuntu 16.04 with AMD? I wasn't able to find a proper driver fo Ubuntu 16.04.

1

On Sunday, I decided to upgrade to 16.04. And have a similar problem. I did as it is written here http://ubuntuforums.org/showthread.php?t=2321874&p=13515588#post13515588 . Radeon R9 390x works fine.


  1. Download crimson drivers from amd site http://support.amd.com/en-us/download.

  2. Then unpack it.

    sh amd-driver-installer-15.302-x86.x86_64.run --extract
    cd fglrx-install. * /
    
  3. And patch

    wget https://raw.githubusercontent.com/im...ernel_4.4.diff
    patch -p1 <fglrx_kernel_4.4.diff
    
  4. Downgrade xserver-xorg to 1.17. remove current xserver package

    sudo apt-get purge xserver-xorg*
    
  5. Commented out the current repository.

    sudo sed -i 's / deb / # deb /' /etc/apt/sources.list
    
  6. Add wily repository in the end of /etc/apt/sources.list.

    deb http://cz.archive.ubuntu.com/ubuntu wily main  
    deb http://cz.archive.ubuntu.com/ubuntu wily-updates main
    
  7. Install the xserver from wily repository.

    sudo apt-get update  
    sudo apt-get install xserver-xorg
    
  8. Hold packages with reduced version xserver.

    packages = `aptitude search xserver | grep -E '^ i' | grep -Eo '(. xserver - +) -' | awk '{print $ 1}'`; for pkg in $ packages; do echo "$pkg hold" | sudo dpkg --set-selections; done
    
  9. Restore the contents of /etc/apt/sources.list.

    sudo sed -i 's / # deb / deb /' /etc/apt/sources.list
    
  10. In the directory with the unpacked driver run:

    sudo sh ./ati-installer.sh 15.302 --install
    
  11. Further installation is in normal mode.

1

AMD has decided to work on the open source drivers rather than providing proprietry drivers. From Ubuntu 16.04 onwards there is no FGLRX and the AMD drivers will not work.

This means you do not have to install anything. Everything should work fine. If it does not then your going to have to wait for the open source drivers to get up to scratch (AMD is working on those now), or go back to an older release of Ubuntu for the moment.

I am using Xenial 16.04 and AMD RADEON HD 6750. It is all working fine so I am wondering if your 'upgrade' is what broke it. I did a clean install.

Refs: http://www.phoronix.com/scan.php?page=news_item&px=Ubuntu-16.04-Dropping-fglrx https://wiki.ubuntu.com/XenialXerus/ReleaseNotes#fglrx

[edit] Steam wont launch on clean install.

cd $HOME/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu
mv libstdc++.so.6 libstdc++.so.6.bak
cd $HOME/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu
mv libstdc++.so.6 libstdc++.so.6.bak

details here http://www.badbod.com/ubuntu-16-04-xenial-amd-steam/ [/edit]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.