0

I'm trying to get sharp fonts on my hidpi screen of gnome Ubuntu 16.04. I can get results with "Sawasdee" font, but not with "Ubuntu Light" font which looks better to my taste.

Any one knows how to make gnome use light fonts in interface?
I.e. "Ubuntu light". If a light font is set, then for some reason its rendered with normal width in majority of applications.

Tweak tool screen shot:

enter image description here

Whats interesting here: in font select box the font is properly shown, with light glyphs (see "Ubuntu light"), while left column is rendered with regular width (see "interface").

Also I've noticed a difference between applications when "light" fonts are selected SegoeUI Light rendering in application menus:

enter image description here

Firefox and LibreOffice render their menus with proper glyphs while gnome-terminal, chrome and tweak tool with bolder glyphs.

This behavior is true for all the fonts with "light" version. The only light font which is properly rendered is Sawasdee. I dot know why.

Can someone tell how to make gnome-terminal render its fonts the way LibreOffice does? Or at least if there is a good light font exists apart from Sawasdee?

  • Do you know if this is specific to 16.04, i.e. did you see different behavior in previous versions? Asking because there was an update of the fontconfig package in 16.04 which treats certain font weights different. – Gunnar Hjalmarsson Jul 9 '16 at 20:36
  • Just tested with 15.10. Results are the same. But i've noticed something similar between fonts: if you look at them in "Font viewer" app and press info, then properly rendered fonts will have "regular" style, but all with problems will have "light" in style. – Lauri Jul 10 '16 at 19:52
  • Then we can rule out the idea the it's a version specific issue, at least. Unfortunately I have no other idea right now; hopefully somebody else has. – Gunnar Hjalmarsson Jul 11 '16 at 2:08
0

After some experimenting i've found the way to force light fonts in interface. You just remove all styles thicker than your desired.

Now my interface is running in thin Roboto, looks stunning on hidpi display. Generally it works this way:

  1. Pick font (Roboto in my case)
  2. Download files from somewhere, fonts.google.com is a good place to start things off
  3. Unpack it
  4. Install only Roboto-ThinItalic.ttf and Roboto-Thin.ttf

Other option is to remove thicker files from /usr/shared/fonts/, i.e. /usr/share/fonts/truetype/ubuntu-font-family/Ubuntu-* and add back light files (Ubuntu-L.ttf, Ubuntu-LI.ttf).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.