2

After upgrading from 15.10 to 16.04, my Nvidia proprietary driver suddenly become not working. The "system is running in low-graphics mode" message appear every-time I boot my laptop with have Nvidia as the primary back-end driver.

I had try and spent half of my the day googling and finding solutions but none of them works for me. I had try :

  • Disabling Secure Boot (following this advise)
  • Re-installing Nvidia v364 (based on this advise)
  • Re-installing Xorg

All above solutions that works for others simply doesn't work for me, the "system is running in low-graphics mode" problem keep appearing no matter how much I have done to solve this problem.

Below is the Xorg.0.log and dmesg log after the time of "low-graphics mode" appeared.

Xorg.0.log

[    59.735] 
X.Org X Server 1.18.3
Release Date: 2016-04-04
[    59.735] X Protocol Version 11, Revision 0
[    59.735] Build Operating System: Linux 3.13.0-86-generic x86_64 Ubuntu
[    59.735] Current Operating System: Linux shahril 4.4.0-28-generic #47-Ubuntu SMP Fri Jun 24 10:09:13 UTC 2016 x86_64
[    59.735] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-28-generic root=UUID=61384bb6-6235-4c1b-a19c-0549eb518562 ro quiet splash intel_iommu=on vfio_iommu_type1.allow_unsafe_interrupts=1 vt.handoff=7
[    59.735] Build Date: 18 May 2016  01:07:07AM
[    59.735] xorg-server 2:1.18.3-1ubuntu2.2 (For technical support please see http://www.ubuntu.com/support) 
[    59.735] Current version of pixman: 0.33.6
[    59.735]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    59.735] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    59.735] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul  9 22:57:18 2016
[    59.735] (==) Using config file: "/etc/X11/xorg.conf"
[    59.735] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    59.736] (==) ServerLayout "layout"
[    59.736] (**) |-->Screen "nvidia" (0)
[    59.736] (**) |   |-->Monitor "<default monitor>"
[    59.736] (**) |   |-->Device "nvidia"
[    59.736] (**) |   |-->GPUDevice "nvidia"
[    59.736] (==) No monitor specified for screen "nvidia".
    Using a default monitor configuration.
[    59.736] (**) |-->Inactive Device "intel"
[    59.736] (==) Automatically adding devices
[    59.736] (==) Automatically enabling devices
[    59.736] (==) Automatically adding GPU devices
[    59.736] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    59.736] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    59.736]    Entry deleted from font path.
[    59.736] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    59.736]    Entry deleted from font path.
[    59.736] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    59.736]    Entry deleted from font path.
[    59.736] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    59.736]    Entry deleted from font path.
[    59.736] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    59.736]    Entry deleted from font path.
[    59.736] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/Type1,
    built-ins
[    59.736] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    59.736] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[    59.736] (II) Loader magic: 0x55b9d858eda0
[    59.736] (II) Module ABI versions:
[    59.736]    X.Org ANSI C Emulation: 0.4
[    59.736]    X.Org Video Driver: 20.0
[    59.736]    X.Org XInput driver : 22.1
[    59.736]    X.Org Server Extension : 9.0
[    59.737] (++) using VT number 7

[    59.737] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    59.737] (II) xfree86: Adding drm device (/dev/dri/card0)
[    59.737] (II) xfree86: Adding drm device (/dev/dri/card1)
[    59.738] (--) PCI:*(0:0:2:0) 8086:0166:1558:7102 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[    59.738] (--) PCI: (0:1:0:0) 10de:13d7:1558:7481 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    59.739] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[    59.739] (II) "glx" will be loaded by default.
[    59.739] (II) LoadModule: "glx"
[    59.739] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[    59.741] (II) Module glx: vendor="NVIDIA Corporation"
[    59.741]    compiled for 4.0.2, module version = 1.0.0
[    59.741]    Module class: X.Org Server Extension
[    59.741] (II) NVIDIA GLX Module  364.19  Tue Apr 19 14:10:52 PDT 2016
[    59.741] (II) LoadModule: "nvidia"
[    59.741] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[    59.741] (II) Module nvidia: vendor="NVIDIA Corporation"
[    59.741]    compiled for 4.0.2, module version = 1.0.0
[    59.742]    Module class: X.Org Video Driver
[    59.742] (II) LoadModule: "modesetting"
[    59.742] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    59.742] (II) Module modesetting: vendor="X.Org Foundation"
[    59.742]    compiled for 1.18.3, module version = 1.18.3
[    59.742]    Module class: X.Org Video Driver
[    59.742]    ABI class: X.Org Video Driver, version 20.0
[    59.742] (II) NVIDIA dlloader X Driver  364.19  Tue Apr 19 13:48:55 PDT 2016
[    59.742] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    59.742] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    59.742] (II) Loading sub module "fb"
[    59.742] (II) LoadModule: "fb"
[    59.742] (II) Loading /usr/lib/xorg/modules/libfb.so
[    59.742] (II) Module fb: vendor="X.Org Foundation"
[    59.742]    compiled for 1.18.3, module version = 1.0.0
[    59.742]    ABI class: X.Org ANSI C Emulation, version 0.4
[    59.742] (II) Loading sub module "wfb"
[    59.742] (II) LoadModule: "wfb"
[    59.742] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    59.742] (II) Module wfb: vendor="X.Org Foundation"
[    59.742]    compiled for 1.18.3, module version = 1.0.0
[    59.742]    ABI class: X.Org ANSI C Emulation, version 0.4
[    59.742] (II) Loading sub module "ramdac"
[    59.742] (II) LoadModule: "ramdac"
[    59.742] (II) Module "ramdac" already built-in
[    59.743] (II) modeset(G0): using drv /dev/dri/card1
[    59.743] (II) NVIDIA(0): Creating default Display subsection in Screen section
    "nvidia" for depth/fbbpp 24/32
[    59.743] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    59.743] (==) NVIDIA(0): RGB weight 888
[    59.743] (==) NVIDIA(0): Default visual is TrueColor
[    59.743] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    59.743] (**) NVIDIA(0): Option "ConstrainCursor" "off"
[    59.743] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration" "on"
[    59.743] (**) NVIDIA(0): Option "IgnoreDisplayDevices" "CRT"
[    59.743] (**) NVIDIA(0): Enabling 2D acceleration
[    59.938] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
[    59.938] (EE) NVIDIA(GPU-0):     check your system's kernel log for additional error
[    59.938] (EE) NVIDIA(GPU-0):     messages and refer to Chapter 8: Common Problems in the
[    59.938] (EE) NVIDIA(GPU-0):     README for additional information.
[    59.938] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[    59.938] (EE) NVIDIA(0): Failing initialization of X screen 0
[    59.938] (II) UnloadModule: "nvidia"
[    59.938] (II) UnloadSubModule: "wfb"
[    59.938] (II) UnloadSubModule: "fb"
[    59.938] (==) modeset(G0): Depth 24, (==) framebuffer bpp 32
[    59.938] (**) modeset(G0): Option "AccelMethod" "None"
[    59.938] (==) modeset(G0): RGB weight 888
[    59.938] (==) modeset(G0): Default visual is TrueColor
[    59.938] (**) modeset(G0): glamor disabled
[    59.938] (II) modeset(G0): ShadowFB: preferred YES, enabled YES
[    59.938] (II) modeset(G0): Output LVDS-1 has no monitor section
[    59.939] (II) modeset(G0): Output VGA-1 has no monitor section
[    60.064] (II) modeset(G0): Output HDMI-1 has no monitor section
[    60.064] (II) modeset(G0): Output DP-1 has no monitor section
[    60.192] (II) modeset(G0): Output HDMI-2 has no monitor section
[    60.320] (II) modeset(G0): Output HDMI-3 has no monitor section
[    60.320] (II) modeset(G0): Output DP-2 has no monitor section
[    60.320] (II) modeset(G0): Output DP-3 has no monitor section
[    60.320] (II) modeset(G0): EDID for output LVDS-1
[    60.320] (II) modeset(G0): Manufacturer: CMO  Model: 1720  Serial#: 0
[    60.320] (II) modeset(G0): Year: 2011  Week: 2
[    60.320] (II) modeset(G0): EDID Version: 1.3
[    60.320] (II) modeset(G0): Digital Display Input
[    60.320] (II) modeset(G0): Max Image Size [cm]: horiz.: 38  vert.: 21
[    60.320] (II) modeset(G0): Gamma: 2.20
[    60.320] (II) modeset(G0): No DPMS capabilities specified
[    60.320] (II) modeset(G0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
[    60.320] (II) modeset(G0): First detailed timing is preferred mode
[    60.320] (II) modeset(G0): redX: 0.640 redY: 0.333   greenX: 0.303 greenY: 0.613
[    60.320] (II) modeset(G0): blueX: 0.154 blueY: 0.060   whiteX: 0.313 whiteY: 0.329
[    60.320] (II) modeset(G0): Manufacturer's mask: 0
[    60.320] (II) modeset(G0): Supported detailed timing:
[    60.320] (II) modeset(G0): clock: 138.7 MHz   Image Size:  382 x 215 mm
[    60.320] (II) modeset(G0): h_active: 1920  h_sync: 1968  h_sync_end 2000 h_blank_end 2080 h_border: 0
[    60.320] (II) modeset(G0): v_active: 1080  v_sync: 1083  v_sync_end 1088 v_blanking: 1111 v_border: 0
[    60.320] (II) modeset(G0):  N173HGE-L11
[    60.320] (II) modeset(G0):  CMO
[    60.320] (II) modeset(G0):  N173HGE-L11
[    60.320] (II) modeset(G0): EDID (in hex):
[    60.320] (II) modeset(G0):  00ffffffffffff000daf201700000000
[    60.320] (II) modeset(G0):  02150103802615780ad895a3554d9d27
[    60.320] (II) modeset(G0):  0f505400000001010101010101010101
[    60.320] (II) modeset(G0):  0101010101012e3680a070381f403020
[    60.320] (II) modeset(G0):  35007ed710000018000000fe004e3137
[    60.321] (II) modeset(G0):  334847452d4c31310a20000000fe0043
[    60.321] (II) modeset(G0):  4d4f0a202020202020202020000000fe
[    60.321] (II) modeset(G0):  004e3137334847452d4c31310a20006e
[    60.321] (II) modeset(G0): Printing probed modes for output LVDS-1
[    60.321] (II) modeset(G0): Modeline "1920x1080"x60.0  138.70  1920 1968 2000 2080  1080 1083 1088 1111 -hsync -vsync (66.7 kHz eP)
[    60.321] (II) modeset(G0): Modeline "1920x1080"x59.9  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.6 kHz d)
[    60.321] (II) modeset(G0): Modeline "1680x1050"x60.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz d)
[    60.321] (II) modeset(G0): Modeline "1680x1050"x59.9  119.00  1680 1728 1760 1840  1050 1053 1059 1080 +hsync -vsync (64.7 kHz d)
[    60.321] (II) modeset(G0): Modeline "1600x1024"x60.2  103.12  1600 1600 1656 1664  1024 1024 1029 1030 +hsync +vsync (62.0 kHz d)
[    60.321] (II) modeset(G0): Modeline "1400x1050"x60.0  122.00  1400 1488 1640 1880  1050 1052 1064 1082 +hsync +vsync (64.9 kHz d)
[    60.321] (II) modeset(G0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz d)
[    60.321] (II) modeset(G0): Modeline "1440x900"x59.9  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync (55.9 kHz d)
[    60.321] (II) modeset(G0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz d)
[    60.321] (II) modeset(G0): Modeline "1360x768"x59.8   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync (47.7 kHz d)
[    60.321] (II) modeset(G0): Modeline "1360x768"x60.0   72.00  1360 1408 1440 1520  768 771 781 790 +hsync -vsync (47.4 kHz d)
[    60.321] (II) modeset(G0): Modeline "1152x864"x60.0   81.62  1152 1216 1336 1520  864 865 868 895 -hsync +vsync (53.7 kHz d)
[    60.321] (II) modeset(G0): Modeline "1024x768"x120.1  133.47  1024 1100 1212 1400  768 768 770 794 doublescan -hsync +vsync (95.3 kHz d)
[    60.321] (II) modeset(G0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[    60.321] (II) modeset(G0): Modeline "960x720"x120.0  117.00  960 1024 1128 1300  720 720 722 750 doublescan -hsync +vsync (90.0 kHz d)
[    60.321] (II) modeset(G0): Modeline "928x696"x120.1  109.15  928 976 1088 1264  696 696 698 719 doublescan -hsync +vsync (86.4 kHz d)
[    60.321] (II) modeset(G0): Modeline "896x672"x120.0  102.40  896 960 1060 1224  672 672 674 697 doublescan -hsync +vsync (83.7 kHz d)
[    60.321] (II) modeset(G0): Modeline "960x600"x120.0   77.00  960 984 1000 1040  600 601 604 617 doublescan +hsync -vsync (74.0 kHz d)
[    60.321] (II) modeset(G0): Modeline "960x540"x120.0   69.25  960 984 1000 1040  540 541 544 555 doublescan +hsync -vsync (66.6 kHz d)
[    60.321] (II) modeset(G0): Modeline "800x600"x120.0   81.00  800 832 928 1080  600 600 602 625 doublescan +hsync +vsync (75.0 kHz d)
[    60.321] (II) modeset(G0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[    60.321] (II) modeset(G0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[    60.321] (II) modeset(G0): Modeline "840x525"x120.0   73.12  840 892 980 1120  525 526 529 544 doublescan -hsync +vsync (65.3 kHz d)
[    60.321] (II) modeset(G0): Modeline "840x525"x119.8   59.50  840 864 880 920  525 526 529 540 doublescan +hsync -vsync (64.7 kHz d)
[    60.321] (II) modeset(G0): Modeline "800x512"x120.3   51.56  800 800 828 832  512 512 514 515 doublescan +hsync +vsync (62.0 kHz d)
[    60.321] (II) modeset(G0): Modeline "700x525"x120.0   61.00  700 744 820 940  525 526 532 541 doublescan +hsync +vsync (64.9 kHz d)
[    60.321] (II) modeset(G0): Modeline "640x512"x120.0   54.00  640 664 720 844  512 512 514 533 doublescan +hsync +vsync (64.0 kHz d)
[    60.321] (II) modeset(G0): Modeline "720x450"x119.8   53.25  720 760 836 952  450 451 454 467 doublescan -hsync +vsync (55.9 kHz d)
[    60.321] (II) modeset(G0): Modeline "640x480"x120.0   54.00  640 688 744 900  480 480 482 500 doublescan +hsync +vsync (60.0 kHz d)
[    60.321] (II) modeset(G0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[    60.321] (II) modeset(G0): Modeline "680x384"x119.6   42.38  680 716 784 888  384 385 390 399 doublescan -hsync +vsync (47.7 kHz d)
[    60.321] (II) modeset(G0): Modeline "680x384"x119.9   36.00  680 704 720 760  384 385 390 395 doublescan +hsync -vsync (47.4 kHz d)
[    60.321] (II) modeset(G0): Modeline "576x432"x120.1   40.81  576 608 668 760  432 432 434 447 doublescan -hsync +vsync (53.7 kHz d)
[    60.321] (II) modeset(G0): Modeline "512x384"x120.0   32.50  512 524 592 672  384 385 388 403 doublescan -hsync -vsync (48.4 kHz d)
[    60.321] (II) modeset(G0): Modeline "400x300"x120.6   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync (37.9 kHz d)
[    60.321] (II) modeset(G0): Modeline "400x300"x112.7   18.00  400 412 448 512  300 300 301 312 doublescan +hsync +vsync (35.2 kHz d)
[    60.321] (II) modeset(G0): Modeline "320x240"x120.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz d)
[    60.322] (II) modeset(G0): EDID for output VGA-1
[    60.448] (II) modeset(G0): EDID for output HDMI-1
[    60.448] (II) modeset(G0): EDID for output DP-1
[    60.580] (II) modeset(G0): EDID for output HDMI-2
[    60.708] (II) modeset(G0): EDID for output HDMI-3
[    60.708] (II) modeset(G0): EDID for output DP-2
[    60.708] (II) modeset(G0): EDID for output DP-3
[    60.708] (II) modeset(G0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[    60.708] (==) modeset(G0): DPI set to (96, 96)
[    60.708] (II) Loading sub module "fb"
[    60.708] (II) LoadModule: "fb"
[    60.708] (II) Loading /usr/lib/xorg/modules/libfb.so
[    60.708] (II) Module fb: vendor="X.Org Foundation"
[    60.708]    compiled for 1.18.3, module version = 1.0.0
[    60.708]    ABI class: X.Org ANSI C Emulation, version 0.4
[    60.708] (II) Loading sub module "shadow"
[    60.708] (II) LoadModule: "shadow"
[    60.708] (II) Loading /usr/lib/xorg/modules/libshadow.so
[    60.709] (II) Module shadow: vendor="X.Org Foundation"
[    60.709]    compiled for 1.18.3, module version = 1.1.0
[    60.709]    ABI class: X.Org ANSI C Emulation, version 0.4
[    60.709] (EE) Screen(s) found, but none have a usable configuration.
[    60.709] (EE) 
Fatal server error:
[    60.709] (EE) no screens found(EE) 
[    60.709] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[    60.709] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    60.709] (EE) 
[    60.712] (EE) Server terminated with error (1). Closing log file.

dmesg (truncated) (full log is here : http://pastebin.com/RZABa15r)

[    0.000000] microcode: CPU0 microcode updated early to revision 0x1c, date = 2015-02-26
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Initializing cgroup subsys cpuacct
[    0.000000] Linux version 4.4.0-28-generic (buildd@lcy01-13) (gcc version 5.3.1 20160413 (Ubuntu 5.3.1-14ubuntu2.1) ) #47-Ubuntu SMP Fri Jun 24 10:09:13 UTC 2016 (Ubuntu 4.4.0-28.47-generic 4.4.13)
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-28-generic root=UUID=61384bb6-6235-4c1b-a19c-0549eb518562 ro quiet splash intel_iommu=on vfio_iommu_type1.allow_unsafe_interrupts=1 vt.handoff=7
[    0.000000] KERNEL supported cpus:
[    0.000000]   Intel GenuineIntel
[    0.000000]   AMD AuthenticAMD
[    0.000000]   Centaur CentaurHauls
...
[    4.235108] [drm] Initialized drm 1.1.0 20060810
[    4.235328] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    4.235333] r8169 0000:03:00.2: can't disable ASPM; OS doesn't have ASPM control
[    4.236092] r8169 0000:03:00.2 eth0: RTL8411 at 0xffffc90001bae000, 00:90:f5:de:76:a6, XID 08800800 IRQ 28
[    4.236094] r8169 0000:03:00.2 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[    4.243933] nvidia: module license 'NVIDIA' taints kernel.
[    4.243936] Disabling lock debugging due to kernel taint
[    4.246824] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    4.248080] ahci 0000:00:1f.2: AHCI 0001.0300 32 slots 6 ports 6 Gbps 0xe impl SATA mode
[    4.248085] ahci 0000:00:1f.2: flags: 64bit ncq stag pm led clo pio slum part ems sxs apst 
[    4.249924] nvidia 0000:01:00.0: enabling device (0006 -> 0007)
[    4.249978] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
[    4.250032] nvidia-nvlink: Nvlink Core is being initialized, major device number 247
[    4.250041] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  364.19  Tue Apr 19 14:44:55 PDT 2016
[    4.250719] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  364.19  Tue Apr 19 14:15:03 PDT 2016
[    4.251167] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
...
[    4.270300] [drm] Memory usable by graphics device = 2048M
[    4.270303] checking generic (d0000000 7f0000) vs hw (d0000000 10000000)
[    4.270304] fb: switching to inteldrmfb from VESA VGA
[    4.270325] Console: switching to colour dummy device 80x25
[    4.270378] [drm] Replacing VGA console driver
[    4.296133] firewire_ohci 0000:05:00.0: added OHCI v1.10 device as card 0, 4 IR + 4 IT contexts, quirks 0x10
[    4.332453] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    4.332456] [drm] Driver supports precise vblank timestamp query.
[    4.353370] [Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
[    4.353422] ACPI: Video Device [PEGP] (multi-head: yes  rom: yes  post: no)
[    4.353555] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:13/LNXVIDEO:00/input/input11
[    4.353713] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[    4.364921] acpi device:45: registered as cooling_device8
[    4.364975] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01/input/input12
[    4.365093] [drm] Initialized i915 1.6.0 20151010 for 0000:00:02.0 on minor 1
...
[    4.613355] usb-storage 3-2:1.1: USB Mass Storage device detected
[    4.613433] scsi host6: usb-storage 3-2:1.1
[    4.613481] usbcore: registered new interface driver usb-storage
[    4.614464] usbcore: registered new interface driver uas
[    4.669552]  sda: sda1 sda2 sda3 sda4 sda5 sda6
[    4.670172] sd 1:0:0:0: [sda] Attached SCSI disk
[    4.756470] fbcon: inteldrmfb (fb0) is primary device
[    4.756557] Console: switching to colour frame buffer device 240x67
[    4.756602] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    4.776005] usb 3-4: new full-speed USB device number 3 using xhci_hcd
[    4.796127] firewire_core 0000:05:00.0: created device fw0: GUID edd4567887654321, S400
[    4.948273] scsi 2:0:0:0: CD-ROM            Slimtype DVD A  DS8A8SH   KX12 PQ: 0 ANSI: 5
[    4.964813] hidraw: raw HID events driver (C) Jiri Kosina
[    4.967994] usbcore: registered new interface driver usbhid
[    4.967995] usbhid: USB HID core driver
[    4.969066] input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/0003:046D:C05A.0001/input/input13
[    4.969137] hid-generic 0003:046D:C05A.0001: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:1a.0-1.2/input0
[    4.977232] sr 2:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[    4.977238] cdrom: Uniform CD-ROM driver Revision: 3.20
[    4.977457] sr 2:0:0:0: Attached scsi CD-ROM sr0
[    4.977559] sr 2:0:0:0: Attached scsi generic sg1 type 5
[    5.295972] ata4: SATA link down (SStatus 0 SControl 300)
[    5.329256] psmouse serio2: synaptics: queried max coordinates: x [..5692], y [..4680]
[    5.427096] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[    5.427141] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
[    5.474042] psmouse serio2: synaptics: Touchpad model: 1, fw: 7.2, id: 0x1c0b1, caps: 0xd04733/0xa40000/0xa0000/0x0, board id: 0, fw id: 582762
[    5.511807] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio2/input/input10
[    5.612587] scsi 6:0:0:0: CD-ROM            OnePlus  Device Driver    0000 PQ: 0 ANSI: 2
[    6.206729] random: nonblocking pool is initialized
[    6.208200] EXT4-fs (sda5): mounted filesystem with ordered data mode. Opts: (null)
...
[   17.888461] lpc_ich: Resource conflict(s) found affecting gpio_ich
[   19.081779] AVX version of gcm_enc/dec engaged.
[   19.081781] AES CTR mode by8 optimization enabled
[   20.775548] ath: phy0: ASPM enabled: 0x43
[   20.775551] ath: EEPROM regdomain: 0x6c
[   20.775552] ath: EEPROM indicates we should expect a direct regpair map
[   20.775553] ath: Country alpha2 being used: 00
[   20.775554] ath: Regpair used: 0x6c
[   20.969350] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   20.969580] ieee80211 phy0: Atheros AR9462 Rev:2 mem=0xffffc90001f00000, irq=18
[   21.004796] ath9k 0000:04:00.0 wlp4s0: renamed from wlan0
[   21.099208] intel_rapl: Found RAPL domain package
[   21.099211] intel_rapl: Found RAPL domain core
[   21.099215] intel_rapl: Found RAPL domain uncore
[   21.122900] nvidia-uvm: Loaded the UVM driver in lite mode, major device number 243
...

Any help is much appreciated.

  • So the open source drivers work fine? – TheWanderer Jul 9 '16 at 15:47
  • @Zacharee1, yes, currently using nouveau as the main driver. But it's not satisfying as me myself is a gamer, using nouveau simply don't fulfill my gaming requirement. :( – Mohd Shahril Jul 9 '16 at 15:49
  • Yeah, Nouveau isn't good for gaming. See what happens if you try installing version 368 using the same method in my Q&A (the one you linked). – TheWanderer Jul 9 '16 at 15:50
  • @Zacharee1, there is no version 368 yet in graphics-drivers's ppa (as I'm concerned), where can I find the other optional links? – Mohd Shahril Jul 9 '16 at 15:58
  • 1
    Glad to hear :D. I saw your answer and gave it a vote. – TheWanderer Aug 29 '16 at 17:08
1

I did it!! It was a problem with the driver itself!

Problem : My Card (NVIDIA GTX980M) doesn't run well with new proprietary NVIDIA Linux driver. Solution : Use the old driver that supports my graphic card.


Basically, after lurking the internet for a while, some people said that maybe I can try to use stable nvidia-352 instead of new drivers.

However, upon looking at apt-cache search nvidia-352, I have found out that nvidia-352 is just a transition driver for nvidia-361 graphic driver.

However, based on my previous test, nvidia-361 up to newest (nvidia-370 at the time of writing) is the source of my problem.

So I need to download the exact nvidia-352 instead of transition nvidia-361.


If you're having the same problem as mine, then below are the steps on how I solved it.

Steps :

  1. Uninstall all your current problematic NVIDIA drivers.

    sudo apt-get purge nvidia-* libcuda-* 
    

    .

  2. Create temporary folder to store nvidia-352 required files

    cd ~/Desktop
    mkdir nvidia-352
    cd nvidia-352
    

    .

  3. Download the required files for nvidia-352 graphic driver.

    wget https://launchpad.net/ubuntu/+archive/primary/+files/libcuda1-352_352.63-0ubuntu3_amd64.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/nvidia-libopencl1-352_352.63-0ubuntu3_amd64.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/nvidia-opencl-icd-352_352.63-0ubuntu3_amd64.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/nvidia-352_352.63-0ubuntu3_amd64.deb
    

    Edit 1:

    If you have problem downloading nvidia-352_352.63-0ubuntu3_amd64.deb from the link above (occurred to me), you can also download it from different sources.

    Here is an alternative link for that file :

    http://mirrors.mit.edu/ubuntu/pool/restricted/n/nvidia-graphics-drivers-352/nvidia-352_352.63-0ubuntu0.15.10.1_amd64.deb
    

    Edit 2:

    The links above is for 64-bit NVIDIA driver, for those who are looking for 32-bit then do a look at below link :

    https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-352
    

    The steps are just the same, just you need to download a different files that support your 32-bit setup.

    .

  4. Install all the debs files.

    sudo dpkg -i *.deb
    

    .

  5. Reboot

    .


Voila! If you booted into your desktop without having a single crash, then you have successfully solved this graphic problem!

Enjoy! :D

0

Ubuntu uses apt-get to install packages and their dependencies. apt-get uses dpkg but will also resolve dependencies which is why it is not recommended you install packages using dpkg.

You will need to enable the multiverse, restricted, and universe repositories for this to work.

Additionally, you should consult the nvidia website to see which driver version you should be using and you do not need to download the driver as you will be using apt-get.

Before you begin, it would be wise to do a full upgrade. I recommend a dist-upgrade. Click here for more info.

The following would be a suggested fix for nvidia-352:

sudo apt-get purge nvidia-* libcuda-*
sudo apt-get update
sudo apt-get install nvidia-352 libcuda1-352 nvidia-libopencl1-352 nvidia-opencl-icd-352

Reboot for the changes to take effect.

Also, in the future, you can search for available packages using the following commands. In this example, we will search for the word "nvidia":

sudo apt-get update
apt-cache search nvidia
  • This one will not works on my particular case, actually if you try apt-cache show nvidia-352, it will shows This is a transitional package for nvidia-361, and can be safely removed after the installation is complete.. So instead of installing nvidia-352 driver, this will install nvidia-361, which in particular is problematic for my laptop before. – Mohd Shahril May 14 '17 at 0:46
  • 1
    Actually the real culprit is the vbios, because my laptop was modded (unknowingly by me) to support Nvidia GTX 980M while officially it can't do that. The new Nvidia drivers (361 and onwards) breaks my old vbios and that is why it shows the errors. Flashing with the new modded vbios solved my problem altogether and I can now install the new drivers without any problem. So cheers. :) – Mohd Shahril May 14 '17 at 0:49
-1

The problem can be solved by

sudo apt purge nvidia-*

Afterwards reboot you pc and the problem is solved.

  • 2
    Welcome tylor to askubuntu! Please format your post in a prettier way! – abu_bua Jun 26 '18 at 23:50
  • You need better answers buddy. – MathCubes Jun 27 '18 at 4:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.