0

Here is the lsusb output

Bus 001 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 001 Device 003: ID 0c45:63e3 Microdia 
Bus 001 Device 006: ID 0e8d:0002 MediaTek Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 413c:02b0 Dell Computer Corp. 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

From my research so far I think that MediaTek is the right device. I read a lot about how to configure the stick, which I think I actually did correctly (with APN and all). I just think the surf stick is not recognized as such. At least it is not show in either the explorer (as an USB medium) or the available network connections. The provider for Internet access would be German company Aldi Talk.

I would appreciate any help to get it running.


PS: Reading the help I noticed that my OS is actually not up to date for this community, but I hope you won't abandon me for this. The OS is running on a Dell Inspiron Mini Netbook with its infamous graphic card. I couldn't get X11 for Arch running anyhow and I'm glad anything runs somewhat stable now. (gedit eats the CPU if not saved every two minutes or so, but hey, I'm not complaining.)

1
  • 14.04 is still supported until 2019, so you're OK for now :p. Jul 9 '16 at 14:34
0

Okay, I think I got it to work, so here is what I did (read completely before trying to reproduce!):

First I configured the network itself. There are enough tutorials how to do this for Aldi Talk under Ubuntu in the net, so I will skip that part.

I installed gammu and configured it as it was suggested from the German site I got the tip from.

sudo apt-get install gammu
gammu-config

Configuration: set Port to /dev/ttyUSB, set Connection to at115200. I couldn't use rmmod usb_storage because the mod was busy, but I tried the other one:

sudo modprobe usbserial vendor=0x0e8d product=0x0002

where vendor and product are from MediaTek Inc. of the output of lsusb (see my question). That didn't returned any errors. So next thing according to the instruction was

sudo gammu -c ${HOME}/.gammurc --entersecuritycode PIN ****

(PIN hidden.) Console gave me

Error opening device, it doesn't exist.

Checking with ls /dev I found that to be true. I tried the routine again, same results, rebooted, tried again, same results. Changed Port to sdb (which is probably the card reader of the netbook), got a different result:

Error opening device. Unknown, busy or no permissions.

Since I couldn't really find other sites in the Internet with this problem, this was about the time I decided to post it here.

Next day. Meanwhile netbook was shut down and booted up a few times as it happens. An idea came to my mind. I was still missing the device, but lsusb said it is there somehow, I just didn't know the proper /dev name. So without having the stick in the laptop:

ls /dev > before.txt

Putting stick in and waiting for it to blink (which it has done all the time before, too)

ls /dev > after.txt
diff before.txt after.txt

Console gave me three new devices:

cdrom
sg2
sr0

I first tried to change the Port to /dev/sg2, started gammu, error: Unknown etc. Changed the Port to /dev/sr0, started gammu, error: Unknown etc. Changed the Port to /dev/cdrom, error: Not existent etc.

HOWEVER directly after that last console return a window plopped up asking me for the PIN (which I actually entered when trying gammu). Then he asked password for the keyring (he usually does) and password for the device (sudo password worked). Checked connections, stick was available. Connected, currently posting through this connection.

I should note that I didn't modprobe this time, usbserial was listed under lsmod (first time since problem that I used that command) and vendor/product ID for MediaTek Inc. returned by lsusb have changed since yesterday.

If it still works after next reboot, I will accept this answer.


Next morning. Just rebooted. ls /dev showed the before-it-worked "files" with cdrom etc. No surf stick showing up in the network connections. Waited a minute. Nothing happened. Then

sudo gammu -c ${HOME}/.gammurc --entersecuritycode PIN ****

Error opening device. Unknown, busy or no permissions. About 10 seconds later the surf stick dialogs show up again. After dealing with that, checked /dev, looked again like yesterday after-it-worked. So somehow the gammu command lets the netbook think about what is really in /dev, even though itself doesn't work. But then again, it works for me even when I'm completely puzzled why.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.