3

I'm having this problem for a long time. when I'm playing a game or working or after some time my mouse stops working! the cursor doesn't move and the left/right clicks won't work. unplugging and replugging doesn't work. only a reboot will. after the mouse stops working, lsusb hangs and doesn't respond with any information.before the mouse stops working lsusb is fine. also the related /sys/bus/usb/devices/usb* folder won't open by nautilus. I don't have any power-management packages installed. and after the mouse stops working, no other mouse or usb port for any device works until I reboot the OS. I've gone over all of the topics related to my mouse in the whole net! so please don't mark it as duplicate! thanks!

  • Does it work on 16.04? Does it work installing 4.4 kernel on 14.04 (linux-image-generic-lts-xenial)? – ignis Jul 9 '16 at 9:23
  • On 16.04, or on 14.04 + 4.4 kernel, please run strace -f lsusb > out.log 2>&1 after it stops working, wait a few seconds, post the file out.log here. – ignis Jul 9 '16 at 9:24
2

You may want to try using the script described by Eli Billauer. The script worked for me up until recently. I am using a USB mouse and keyboard, with a desktop computer (no trackpad).

I made a small modification (included ehci-pci interface in addition to xhci), so I'm going to post the exact script that I'm using here so you can compare with what Eli does. Note that you must run this script as root (sudo it):

#!/bin/bash

for xhci in /sys/bus/pci/drivers/xhci_hcd /sys/bus/pci/drivers/ehci-pci ; do

    if ! cd $xhci ; then
        echo Weird error. Failed to change directory to $xhci
        exit 1
    fi

    echo Resetting devices from $xhci...

    for i in ????:??:??.? ; do
        echo -n "$i"
        echo -n "$i" > unbind
        echo -n "$i" > bind
        echo "reset $i"
    done
done

Caveat: the script stopped working as of June 2016. I have the same problem as you, Amir: my USB mouse fails sporadically. I will be right in the middle of moving the mouse around and kablam, the mouse turns off, and stops responding (the light on the mouse goes off). Sometimes this happens days after rebooting the system, sometimes hours.

FWIW, lsusb simply hangs. In response to ignis' comment above, strace -f lsusb > out.log 2>&1 also hangs so I can't provide any info from that.

One more comment: this is not a case where the OS stops responding entirely. It's just the mouse. I can still use the keyboard, and I can also log in from another system and try things once the mouse stops.

  • I believe the issue that I was having was due to using wired mouses. I tried fixing this issue using 3 different wired mouses that I owned, and all had the problem that the mouse failed sooner or later. I bought a wireless mouse, and in the last 2 months, the problem has not occurred. If you've had this problem, try a wireless mouse. Note: my keyboard is wired, no problems there. I do sometimes get a strange jerkiness with the new wireless mouse. It can last for a couple of minutes, and then goes away. It happens once ever few days. – dragons Oct 15 '16 at 18:29

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.