I have little prolem that when open up chrome, gnome keyring starts to use cpu on 11%. If i start chrome from command line with google-chrome --password-store=basic this bug is not present.

The ugly method chmod +x gnomekey... not acceptable

Also I have tried to not set password for "default keyring" to not ask for password, but keyring still uses high cpu.

I also have basic error messages like cannot securely allocate, or /run/user/1000/keyring/control: Connection refused. (The file control doesn't exist.)

I have also noticed some weird thing that the Default_keyring.keyring is updating/re-creating every second(or faster) and it ends only when I kill the keyring process.

ulimit -l = unlimited already edited in /etc/secur....

Some system info: Ubuntu 16 latest fully updated including latest chrome fully updated. i7-6700HQ, 8gig ram, etc..

But is there any way to start Chrome with --password-store=basic? NOTE that I really mean always, not only when I click on Chrome icon, but also when Chrome is completely closed and I click on a link in mail client/skype/any application.

So I'm wondering if there is something like startup_args.config file (I haven't found anything like that in profile directory) and also not found password store option in chrome://flags

Thank you for you time and help.

P.S.: I will be really happy if someone can explain me why from 2008 until today are people reporting this error with chrome/ium and gnome-keyring. And also why it happens. It feels like chrome cannot create keyring or fill it with saved passwords.


I had this issue with Chromium and the only acceptable workaround that I've found is to use KDE's KWallet instead of Gnome Keyring.

These are the steps I took:

  1. Backup Chromium data directory ~/.config/chromium
  2. Install kwalletmanager: sudo apt-get install kwalletmanager

  3. Perform a sync with google servers then delete Chromium data directory. (not sure if this is essential)

  4. Add/replace --password-store=kwallet to Chromium launch parameters
  5. KWalletManager should display when you open Chromium for the first time asking for new wallet passphrase.
  • Thank you, i am using windows actually but tried on vbox seems to work. – Erik Kubica Oct 3 '16 at 8:45

Since there was no help i have decided to create alternative script to launch by

mv /usr/bin/google-chrome /usr/bin/google-chrome-orig

nano google-chrome

with content

google-chrome --password-store=basic

then i made it executable

so now chrome starts with this command anytime anywhere, not just only by clicking on shortcut

  • 1
    You know that this disabled password encryption? There is a reason for Chrome using GNOME Keychain by default, after all. – YtvwlD Jul 10 '16 at 7:46
  • 1
    @YtvwlD You are correct of course that said if the user account has an encrypted home directory that would provide similar protection to the default keyring which is generally unlocked by the user account password at session start just like the default ecryptfs filesystem. Still identifying the cause of the problem and fixing it would probably be the better option in the long run. – MttJocy Jul 10 '16 at 8:54
  • Yes i know that now passwords are not encrypted, even my home directory is not encrypted. But i don't care about it. I needed an alternative solution, to use chrome without always killing the keyring process after everytime chrome started. i just cant understand if generaly speaking linux and chrome is so popular, why the thell is there no a single functional fix for that. – Erik Kubica Jul 10 '16 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.