I have a little problem with the NVIDIA driver. I've built a PC for scientific computations on which I'm running MATLAB and other programs.

To speed up the computations I've included a NVIDIA Quadro K5000 to take advantage of the CUDA capabilities of MATLAB.

Unfortunately, I have a little problem. When I'm using the nouveau driver everything is working fine, but of course I'm missing the CUDA support of MATLAB. When I install the NVIDIA driver from the repository (nvidia-361) as well as the nvidia-cuda-dev/nvidia-cuda-toolkit packages I can open MATLAB but almost every other graphical program doesn't open.

When I try to start them over the command line I get the error

"Segmentation fault (core dumped)". 

I tried using other versions, but with the nvidia-352 driver I have the same error and the nvidia-304 driver is apparently too old to support CUDA. Does anybody know how I could fix the Segmentation fault error when using the newest NVIDIA drivers?

2 Answers 2


get the CUDA 8.0 package from nvidia


This packages up all the cuda libs and matches them with drivers.

  • That pushed me in the right direction, I've didn't install the CUDA 8.0 drivers, but the currently most up to date driver from the NVIDIA site (367.27) as well as the most up to date CUDA version from the NVIDIA site cuda_7.5.18_linux.run. Now I have the MATLAB cuda support as well as being able to launch other graphical programs.
    – user143507
    Jul 8, 2016 at 12:36

I've solved this issue with the help of Amias feedback. Instead of using the drivers provided by Ubuntu, I've download the newest versions of the GPU driver (367.27) as well as the CUDA toolkit (cuda_7.5.18_linux.run) and installed them by hand. Now I have CUDA support in MATLAB as well as being able to launch other graphical programs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.