I have a very peculiar situation. I installed a piece of software by building it from source. I used "make install" from the folder that I downloaded it into (on my desktop). Later on, after not using it for a while, I decided I don't need the folder on my desktop and shift-deleted it. Most files in that folder were deleted, but some of them cannot. It says I have no permissions to do it.

What I am assuming is that those files are used by the kernel, because the software was built from source. Is this correct, and if so, how can I delete them? Can I boot in another kernel or do something like Windows's safe mode?

sudo rm -rf ~/Desktop/<path_to_folder>

The reason you cannot remove that folder is that during compiling and installation some files where created with administrator privileges (probably using sudo), you wont be able to remove those with your account.

Its not that the files are being used at the moment, you simply don't have any rights to delete them.

Use the command above to delete the files under that folder, it will grant you privileges to remove it.

  • Damn. I tried this without sudo before asking the question. Now it worked, don't know why I didn't try that. Thanks! – Slavo Nov 16 '11 at 19:13

When you do "make install", the program files are copied to system. Those files you can't delete probably belong to root. To delete them, hit Alt+F2 and execute:

gksu nautilus ~/Desktop

This will open a Nautilus window, from where you can delete the folder you need. Please note that this Nautilus window has root access to files, so when you delete what you need close it :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.