0

So the problem started when my steam client was updating, then i went to the market and when i came back there was this big screen full of text and it was stuck and i couldnt switch to any other tty, so i shutdown the laptop manually and whenever i boot it first grub comes up then i see a bunch of text starting with [ok] then it stops at

[ OK ]  Mounting arbitrary file formats

Note that the last line differs each time i boot up. And after this text it transfers to tty1 and there is the ubuntu logo with five dots ( the usual boot process) and it gets stuck here... All the other tty s are blank.

Edit 1: k after many many times of booting i have noticed smthing strange, now i can only switch to tty2 + tty6 and when i double switch it goes back to graphical view. And in tty 2 + 6 it says

Welcome to emergency mode! After logging in, type "journalctlb -xb" to view system logs, "systemctl reboot" to reboot, "systemctl default" or ^D to try again to boot into default mode. <

2
  • After edit 1, i just lost it and hit every key on the keyboard, now all other ttys are accessible but back in graphical view all the five dots under ubuntu logo are all orange...
    – Ldddd
    Jul 7, 2016 at 19:06
  • Please help me!
    – Ldddd
    Jul 8, 2016 at 14:58

1 Answer 1

0

Ok, atlast i fixed it, i went into recovery mode and selected root shell, first i ran e2fsck -p /dev/sda1 which gave an error thqt said I should fsck manually without -p or -a flags and i did. It worked. And everything is fine now, but i rlly dont understand how a steam upd can mess up my filesystem...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .