1

~Ubuntu 14.04

~Intel® HD Graphics 5500 (Broadwell GT2) x86/MMX/SSE2

I am experiencing "An unknown DirectX error has occurred..." crash msg and one of the solutions I found so far is to update graphics drivers, but here I came across THIS problem.

Every time I try to install Intel-linux-graphic-installer package, either through the official .deb (that I open through GDebi) or Ubuntu software center, I get: "Error: Dependency is not satisfiable: libgtk-3-0 (>=3.16.2)".

Plz save ma lyf.

Ty community <3

4
  • Which version are you trying to install? And DirectX is a Windows graphic thing. What does it have to do with Ubuntu? – dadexix86 Jul 7 '16 at 15:26
  • I am trying to install intel-linux-graphics-installer_1.4.0-0intel1_i386.deb And I need DirectX to run a game through Wine. – Lokner VI Jul 7 '16 at 15:32
  • That installer does not work with releases older than 15.10, as explicitly written there. Ypu have to use an older one, I write an answer. – dadexix86 Jul 7 '16 at 15:33
  • For the crash, report a bug against Wine. If the game is available for Linux natively, it would be better to use the Linux version. If you must play the game, and it's only available for Windows, then a VM or dual booting might be better options. Also, you can contact the developer/publisher of the game, and tell them you want to play it on Ubuntu. – dobey Jul 7 '16 at 16:03
0

From Intel website for Graphics Installer 1.4.0

This release of the Graphics Installer is targeted at Ubuntu 15.10 or Fedora 23. Ubuntu 16.04 is already current with the latest Q1 2016 Intel Graphics stack and therefore no Graphics Installer is needed.

Support is deprecated for Ubuntu 15.04 "vivid" and Fedora 22. Please consult your distribution's documentation for upgrade instructions to newer OS revisions.

The latest installer that supports 14.04 is version 1.0.6

But I sincerely doubt that this is the right way to solve that problem with DirectX, because the latest graphic stack in 14.04 should already overcome the "Intel® Graphics Stack Release 2014Q2 for Linux" that is supported by that installer.

3
  • Thank you very much! Was hella silly of me to miss that crucial detail :( However, on 1.0.6 page it says that "This release is no longer supported." so I got nothing to download. Regardless, my main problem is to deal with the DirectX error, any recommendations? – Lokner VI Jul 7 '16 at 15:57
  • Yes, accept this answer because it was useful and then open another question explaining exactly what you are trying to do and the setting (wine version, game version, how you installed and such) – dadexix86 Jul 7 '16 at 16:06
  • Yes true thank you very much you've explained a necessary bit for me! :) – Lokner VI Jul 7 '16 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.