2

Asking for some help. Been beating my head on the wall for several days now. Trying to extend the life of my MAC PowerPC G5 (with OS 10.4) by installing Linux on its second hard drive (and then making it a dual boot system). Have gone here (http://cdimage.ubuntu.com/releases/12.04.4/release/)and (http://gb.archive.ubuntu.com/ubuntu/dists/) to download the ISO files. Have then burned them to DVD-R with imgburn; to make a bootbale install dvd. So far have tried Ubuntu 12.04 and 14.04; and Lubuntu 12.04 and 14.04. I have the exact same issue with each. I boot to cdrom. Whether i type "live" or one of the other options (tab menu) or just hit ENTER, i get the same result. The black screen with white text runs; changes to a white screen with black text; then changes to a blank black screen. then it sits there forever. So it never installs at all. Before Ubuntu i tried both Debian 8.5 and the test version of Debian 8.5. Both install without an issue or error, but when i reboot after the install, i get a FAILED to start LOAD KERNEL MODULES error and the boot fails. And i did format\reinstall 3 times. So i feel like i am out of ideas here. I wanted Ubuntu or Ubuntu Studio, but at this point just want a working Linux distro.

Has anyone run into this before ? Have any suggestions ? Certainly appreciate any help. Thanks.

5
  • Which specific ISO files did you try? – Nick Weinberg Jul 7 '16 at 13:10
  • thank you for answering. lubuntu-12.04-desktop-powerpc; lubuntu-14.04.4-desktop-powerpc; and ubuntu-12.04-desktop-powerpc. and the 14.04 version of that ubuntu iso as well. all off the official site. straight download, not a torrent. – PAK5000 Jul 8 '16 at 2:30
  • If I were you, I'd try out one of the -alternate-powerpc images (instead of -desktop-powerpc). It uses a text-based installer and might work better for you (or it might not, but there's only one way to find out!) The "alternate" image is available for Lubuntu, and might be available for the other flavors. – Nick Weinberg Jul 8 '16 at 2:34
  • that also failed. So, of the 11 distros i have tried so far, all the variations of ubuntu\lubuntu failed to install. miint ppc installed with errors then would not boot. both debian distros installed fine but would not boot. i can't think all those distros are broken. there must be some sort of pre-requisite file the MAC needs that is missing. But damned if i knwo what it is\are. any ideas ? thanks. – PAK5000 Jul 11 '16 at 12:45
  • I saw this guide a little while ago and it looks pretty comprehensive. reddit.com/r/linux/comments/4pry3i/… Apparently Apple makes it difficult to boot any OS that's not Mac OS, but there are ways around it, as described in that guide – Nick Weinberg Jul 11 '16 at 12:58
0

i did get some suggestions about overwriting the mac os with linux , which made me think the issue was with the MBR on the primary hard drive. so i yanked out both hard drives and put two new drives in. installed debain 8.5 on the primary drive. rebooted. and got past the "failed to start LOAD KERNEL MODULES" error. got 3 screens further. actually saw the log in screen , but before i could type anything the screen went to black with a non-blinking cursor, then the screen broke up into a cool looking b/w pattern. so made progress but still no actual success.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.