1

I have a major issue - a few hours ago I updated my kubunt 14.04 machine - I delayed this update a bit since I did not want to reboot my machine. Since KDE Startmenu did not appear anymore when I clicked I decided to update and reboot then.

Now I cannot login to KDE anymore! The symptoms are:

  • I can enter the password, but when I press [Enter] NOTHING happens (NO black screen that flashes or else)
  • the password does not get cleared
  • if I enter a wrong password exactly the same happens
  • guest can login to KDE
  • I can login in tty
  • created a new user: it cannot login

Yes, I looked at and tried all the hints regarding .Xauthority etc. I renamed it, I changed permission etc. nothing helps. Below I post /varlog/lightdm/lightdm.log after 1 login try with (hopefully) correct password since from what I see there I do not get better hints from google, stackexchange or askubuntu. May be it's related to the fingerprint reader or other hardware.

This is my main workplace machine so any fast advice or hint is greatly appreciated!

~$ sudo cat /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.10.6, UID=0 PID=1311
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/40-kde-plasma.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/40-lightdm-kde-greeter.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Registered seat module xlocal
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.00s] DEBUG: Registered seat module surfaceflinger
[+0.00s] DEBUG: Adding default seat
[+0.00s] DEBUG: Seat: Starting
[+0.00s] DEBUG: Seat: Creating greeter session
[+0.00s] DEBUG: Seat: Creating display server of type x
[+0.00s] DEBUG: Deactivating Plymouth
[+0.03s] DEBUG: Using VT 7
[+0.03s] DEBUG: Seat: Starting local X display on VT 7
[+0.03s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+0.03s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+0.03s] DEBUG: DisplayServer x-0: Launching X Server
[+0.03s] DEBUG: Launching process 1323: /usr/bin/X -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.03s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+0.03s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.03s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.05s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.05s] DEBUG: User /org/freedesktop/Accounts/User1001 added
[+0.08s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.18s] DEBUG: Got signal 10 from process 1323
[+0.18s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+0.18s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+0.18s] DEBUG: Quitting Plymouth; retaining splash
[+0.20s] DEBUG: Seat: Display server ready, starting session authentication
[+0.20s] DEBUG: Session pid=1345: Started with service 'lightdm-greeter', username 'lightdm'
[+0.21s] DEBUG: Session pid=1345: Authentication complete with return value 0: Success
[+0.21s] DEBUG: Seat: Session authenticated, running command
[+0.21s] DEBUG: Session pid=1345: Running command /usr/lib/lightdm/lightdm-greeter-session /usr/sbin/lightdm-kde-greeter
[+0.21s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
[+0.21s] DEBUG: Session pid=1345: Logging to /var/log/lightdm/x-0-greeter.log
[+0.22s] DEBUG: Activating VT 7
[+0.22s] DEBUG: Activating login1 session c1
[+1.37s] DEBUG: Session pid=1345: Greeter connected version=1.10.6
[+137.95s] DEBUG: Session pid=1345: Greeter start authentication for ursin
[+137.95s] DEBUG: Session pid=1811: Started with service 'lightdm', username 'ursin'
[+138.97s] DEBUG: Session pid=1811: Got 1 message(s) from PAM
[+138.97s] DEBUG: Session pid=1345: Prompt greeter with 1 message(s)
[+138.97s] DEBUG: Session pid=1345: Continue authentication
[+176.29s] DEBUG: User /org/freedesktop/Accounts/User1000 changed
[+241.69s] DEBUG: User /org/freedesktop/Accounts/User1000 changed

if I do more than 1 login try I do also get messages like

[+2046.48s] DEBUG: Session pid=1345: Greeter start authentication for ursin
[+2046.48s] DEBUG: Session pid=1811: Sending SIGTERM
[+2046.48s] DEBUG: Session pid=2001: Started with service 'lightdm', username 'ursin'
[+2046.48s] DEBUG: Session pid=1811: Terminated with signal 15
[+2046.48s] DEBUG: Session: Failed during authentication
[+2046.48s] DEBUG: Seat: Session stopped

and that repeats then infinitely...

3

I figured it out phewww - the system was basically useless!

Instead of reporting what did not work (e.g. looking at x-0-greeter.log), I will try to summarize what worked. I assume not many people having this issue as it is caused by fingerprint-gui.

$ sudo cat /var/log/lightdm/lightdm.log

At some point I started comparing my (buggy) log to one in which the login succeeded and this hinted on auth to causeing the issue, since I never got the second line here:

[+24.30s] DEBUG: Session pid=1769: Continue authentication
[+24.31s] DEBUG: Session pid=2005: Authentication complete with return value 0: Success

$ tail -n 50 /var/log/auth.log

showed amongst a lot other stuff, this:

pam_fingerprint-gui[8676]: Got password by keyboard.
pam_fingerprint-gui[8676]: Return 25 (PAM_IGNORE). 

which led me to http://home.ullrich-online.cc/fingerprint/Forum/topic.php?TopicId=546#1504

the post reads:

June 17th, 2016 11:57pm
Wolfgang, Maurizio,

I can report similar problems here!

I have been using fingerprint-gui for years (thank you Wolfgang !!) on Kubuntu 14.04

Since v1.08 update, I can only login with fingerprint, typing the password would freeze it. Once logged in, all authentication by password failed. On a Konsole, any sudo command would behave like a wrong password was entered (and I would be "reported"!! ) a bit like it got a failed password even before asking for it.

Didn't test much, but felt like non-kde application (synaptic for examples) behaved better than native kde (muon)

At the moment I've temporarily uninstalled fingerprint-gui, I hope you can fix this, please let me know if there is something I can do to help?

Jyves.

this was (a) the first recent post (1 month ago - but remember that I delayed the update a bit) that (b) pointed out that it worked for years but stoped due to a recent update. And (c) removing fingerprint-gui helps:

$ sudo apt-get purge fingerprint-gui
$ sudo apt-get purge libfakekey0 libfprint0
$ sudo shutdown -r now

Issue solved for me! (Thanks to clonezilla debugging and extreme testing was easy! And a sudo touch /forcefsck; sudo shutdown -r now at the end is always a good idea!)

Open question: How to replace fingerprint-gui on lenovo hardware?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.