0

I recently got my server and I did a major noob mistake. I forgot to allow my modified ssh port on ufw. Now I can't ssh into it. It's a remote dedicated server. So that means I have to ask the host to allow it?

  • 1
    yup!! you have to ask host. No other way around – rɑːdʒɑ Jul 7 '16 at 4:30
  • Thank you. I hope the host doesn't have to do a complete reinstall? – RyanB Jul 7 '16 at 4:31
  • Yes, No need to. You can request service desk or help desk – rɑːdʒɑ Jul 7 '16 at 5:18
  • Some VPS hosts provide a web-based serial console, or some other way of accessing your server directly (even if you don't have something like SSH installed for remote access!). You might want to check to see if your host offers something like this. – Nick Weinberg Jul 7 '16 at 9:35
  • As a safety precaution it can be a good practice to temporarily disable ufw auto-startup at boot (i.e. in Ubuntu 16 you would do systemctl disable ufw). That way if you lock yourself out when you cycle ufw (ufw disable && ufw enable), you can reboot the system and ufw will be offline. If following this suggestion, don't forget to re-enable ufw (systemctl enable ufw) once you've confirmed that access is ok after cycling ufw. – Ville Jan 9 '17 at 4:50
-1

Ordinarally Raja would have the reason. If it is on amazon cloud, you could set up another server, and attach the other server storage and change the config by hand. You have to know the provider features. Perhaps there are ways. Many "dedicated servers" aren't trully that. Ask for your host support.

Or hire a whitehat pentester to try to do so if it is legal on your country. On my country is legal, as long as the servers is really yours.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.