4

I'm using zsh as my default shell.

I installed byobu and it seems to work fine, however I have to launch it manually every time I start a terminal instance (Ctrl+Alt+T).

I checked byobu-config and it says

Byobu currently launches at login (toggle off)

But it's not the case. I tried toggling this option, but it doesn't change anything and I still have to run byobu whenever I start a terminal.

Is there a way of forcing byobu to be launched whenevr I start a terminal?

Thanks!

1 Answer 1

3

I don't use zsh but I had this problem with the standard terminal application on Ubuntu and Linux Mint (gnome-terminal). I believe that the 'byobu-config' command only enables byobu for remote log-in, for example through ssh. In my case byobu-config had added the following line at the end of ~/.profile to enable byobu for remote log-ins:

_byobu_sourced=1 . /usr/bin/byobu-launch 2>/dev/null || true

I added the same line to the end of ~/.bashrc and it then worked for the local terminal too. Presumably zsh has a similar configuration file that you can edit.

1
  • 1
    this line is added when you launch byobu-enable command, but I doesn't work for me.
    – logoff
    Jul 11, 2017 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.