1

I have an IBM bladecenter with 5 blades installed. Internally, the blades are connected to each other (I know this becuase I have a second one and I do not have this problem).

However, when I go to run ifconfig, I do not have an IPV4 address for the private network. It is as if the blades are not connected to each other. All I get is the IPV6. My case is similiar to this post (how to obtain ipv4 address of ubuntu server running in virtual box along with ipv6?) I have tried the fixes that the answer gave; however, these did not work. (My ifconfig screen looks similiar to the OP)

I have tried to setup my own connection in ubuntu but this did not work at all.

Has anyone ran into this issue before?

0

I'm no IBM bladecenter speciallist, but look: try, if you have gnome network connection manager, ticking the "require ipv4 addressing for this connection to complete" Or try setting up your DHCP to issue both ipv4 and ipv6 adresses (if this have changed in anyway)

2
  • Thank you for the comment, I have been looking everyone for some setting that will set the DHCP server internally; however, I am starting to believe that there is none – philm Jul 7 '16 at 16:29
  • If it is a linux, it sure has... take a look on [linux.die.net/man/5/dhcpd.leases] ... try deleting the leases files or modifing them, among with issuing both ipv4 and ipv6 addresses. – Cloacker Jul 7 '16 at 20:18
0

Ok so after some experimenting, I figured it out. It is quite simple and I am surprised that I didn't think of this before.

In the network options when you go to edit the connection, I manually set the IP address of each blade to be on the same subnet. Afterwards, it was able to connect and everything works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.