3

I know this question may seem similar to When I turn the monitor on, I get an “input out of range”, how do I fix this?, but it certainly isn't. My question, although causing the same error, happens when I'm trying to install ubuntu. So I've made my computer first boot from the USB, and this works - after it's booted a little bit, it comes up with a black screen, with text which is basically some options. I select the option to install Ubuntu.
My monitor turns black, but I can tell that it's still on. After a few seconds, I get told that my monitor is out of range (or something along these lines - I can't remember exactly).
The monitor I'm using is a BenQ EW2440, and this is what's telling me the error, as it's displayed in the format which my monitor usually tells me stuff.
So, how can I get past this black screen?

  • re-install again – Mudit Kapil Jul 6 '16 at 19:29
  • @MuditKapil what do you mean?\ – Jacob_ Jul 6 '16 at 20:04
  • re-install and give details of errors – Mudit Kapil Jul 6 '16 at 20:08
  • okay - when I try to re-install, the screen goes black, and my monitor tells me "out of range" – Jacob_ Jul 7 '16 at 15:29
  • 1
    @MuditKapil thanks - that's not very specific though, are there any links which could help me? – Jacob_ Jul 8 '16 at 19:29
1

1.) When running the installer, just before the error occurs, you will see this cryptic screen:enter image description here
2)That cryptic little keyboard next to that cryptic little man apparently means “press any key.” If you do that, a menu will pop up. First, select a language, then press F6 (“Other Options”). A new menu will pop up; use the arrow keys to move to “nomodeset”, and press Enter to select it. Press Esc to dismiss the menu. Then you can proceed with the installation as normal.

3.)Of course, this only works for the installer. When you first try to boot your newly installed system, you will get the same error as before. To boot, you will need to add nomodeset to the kernel command line. When you boot the machine, wait for the GRUB menu to appear. (If the menu does not appear, you may need to hold down the Shift key when booting.)

enter image description here

Press e to edit the kernel command line:

enter image description here

Add nomodeset right after quiet splash:enter image description here

Press Ctrl+x to boot

3.) Of course, editing the kernel command line only affects the current boot process; the next time you boot the machine, you will have to manually add nomodeset again. To fix the problem permanently:

If you have an NVIDIA video card, installing the proprietary NVIDIA driver may make the problem go away.
Alternatively, you can edit the file /etc/default/grub and change the line

GRUB_CMDLINE_LINUX=""

to

GRUB_CMDLINE_LINUX="nomodeset"

Then run

sudo update-grub
  • the problem is that from the installer usb, i get an option to install ubuntu. After selecting this, the screen goes black and my monitor tells me that it's out of range that cryptic screen never comes up – Jacob_ Jul 14 '16 at 16:53
  • @Jacob_ It comes for some time and when you press Enter than install Ubuntu option comes. – Mudit Kapil Jul 14 '16 at 17:15
  • well it doesn't seem to, at least for me - is there any way I can show you what does happen? – Jacob_ Jul 14 '16 at 17:20
  • @Jacob_ Yes you can post a screen shot or take a picture from camera and post in your question as Edit. – Mudit Kapil Jul 14 '16 at 18:19
  • okay i'll try that – Jacob_ Jul 14 '16 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.