3

After upgrading from 14.04 to 16.04 Lyx has trouble opening documents I created or creating new documents from templates like dinbrief where it says that some files are corrupted, the basic module that is required or some other files or dependencies could not be found.

I reinstalled Ubuntu instead of doing an upgrade and restored a backup of the home directory. I made a list of packages that were installed and only picked the packages and applications I still use. I have been doing this for a few years now for LTS and non-LTS releases and I'm confident that I didn't miss something important, basically installing the lyx meta package and some recommended packages should give me a working setup.

Since it said the files are corrupted – 😱 – I tried reinstalling the related Lyx and Texlive packages that apt remove auto completion offered me but without success. How can I solve this problem? Are my files or the installation corrupted?

4

The solution was to open Lyx and from the menu go to ToolsReconfigure, then restart Lyx and everything worked like before again.

screenshot of the tools submenu and the reconfigure option

It doesn't look like Lyx intended to say "your (Ubuntu) installation is corrupted" just that I couldn't make sense of the old configuration it found.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.