15

I am not able to copy paste using keyboard shortcuts (CTRL+V and CTRL+C). It is not working globally on my Ubuntu 16.04. CTRL+A is working fine however. How can I fix it? I would be able to add a custom shortcut? If yes, please tell me how. Thanks.

based on the comments:

  1. I am not able to use the shortcuts in GEdit.

  2. I have only one keyboard layout (hopefully US English).

  3. I cannot find any options which list CTRL+V and CTRL+C in keyboard shortcuts. As a matter of fact, I cannot see anything that has copy or paste among keyboard shortcuts.

  4. CTRL+SHIFT+C/V is also not working on Gnome Terminal.

xev output:

KeyPress event, serial 34, synthetic NO, window 0x3600001,
    root 0xe6, subw 0x0, time 21190334, (-274,200), root:(463,252),
    state 0x0, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x3600001,
    root 0xe6, subw 0x0, time 21190419, (-274,200), root:(463,252),
    state 0x4, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  4294967252 0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

Update :

I am able to use ctrl + Insert for Copy and shift + Insert for paste.

11
  • 1
    Those keys are not global. gnome terminal for instance uses shift ctrl c and shift ctrl v for cut and paste.
    – ubfan1
    Jul 6 '16 at 15:13
  • 3
    Can you please edit your question, to include possible places where your shortcuts don't work, for example in terminal it is not ctrl+c/v it is instead ctrl+shift+c/v, see as well how to ask a good question. Thank you.
    – Videonauth
    Jul 6 '16 at 15:13
  • Unless I'm in a browser, I find myself right-clicking and selecting copy or paste as this always works.
    – Delorean
    Jul 6 '16 at 16:28
  • Check if you have two layouts Keyboard as it is possible the first layout is not English
    – Zuko
    Jul 6 '16 at 16:38
  • You can try Keyboard -> Preferences -> Keyboard Shortcuts and edit the shortcut for ctrl-c or simply use a mouse
    – Zuko
    Jul 6 '16 at 16:45
6

I have stumbled across a fix. In the Keyboard and mouse tab of gnome-tweak-tool. I enabled Show All Input Sources and Show location of Pointer and as if by magic Ctrl is behaving as expected. Weird, does this also work for you?

4
  • I just tried what you said @GreggC2006 . But without no success.
    – user227495
    Jul 11 '16 at 19:59
  • enabled 'Show All Input Sources' works for me, tks! Jan 25 '18 at 15:35
  • 2
    Enabled 'Show Extended Input Sources', worked! Thank you! Feb 14 '19 at 20:43
  • Doesn't work in terminal.
    – CaTx
    Jun 8 '19 at 2:36
0

On Ubuntu 18.10, I switched the Desktop Environment from Ubuntu to Ubuntu Wayland and it worked.

1
  • Try to avoid abbreviations in answers, or spell out the words the first time, and include the abbreviation in parenthesis. Some users might not understand DE is Desktop Environment. Apr 13 '20 at 13:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.