This question already has an answer here:

I am using Ubuntu 16.04 with GTX 1080. On my first boot, the screen turn black after I selected Ubuntu in grub. After I added nomodeset, the black screen gone however it only shows the Ubuntu default background image. It can't reach the login screen.

marked as duplicate by David Foerster, Pilot6, Charles Green, waltinator, Eric Carvalho Sep 29 '17 at 16:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please also consider the other answers of the linked question beyond the nomodeset parameter. – David Foerster Sep 28 '17 at 18:32

I had this problem with my 1080 and just solved it yesterday. You'll need to install using integrated graphics, install nvidia drivers, then switch back to the 1080.

First, make the live USB for Ubuntu. Go into your BIOS settings, and enable both iGPU and the GPU. Plug in your monitor to the HDMI port on the motherboard, and install Ubuntu as normal. After installation, boot Ubuntu and install the nvidia-367 drivers. Once that's done, you can plug your motherboard back into the the GPU and use Ubuntu.

Here's the PPA you need for nvidia-367: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

One problem I haven't solved is that the monitor turns off while Ubuntu is loading. It turns back on at the login screen. Not sure why :/

  • 1
    Your proposal is to remove the physical 1080 card, and use an integrated video card instead temporarily? What if the mainboard doesn't have integrated graphics available? – gravitymixes Jul 8 '16 at 13:13
  • I used the BIOS settings to enable integrated video without physically removing the GTX 1080. Removing the card temporarily should work as well. – sargunster Jul 8 '16 at 14:40
  • If integrated graphics are not available, then I don't have a solution for that :/ This can at least help those who do have integrated graphics. – sargunster Jul 8 '16 at 14:41
  • Maybe a workaround would be to plugin an old video card in such a case. Although this seems like an awful hassle only to make it the 1080 work. – Cat Jan 3 '17 at 21:26
  • I ran into this problem with my Zotac zbox en1070 which does not have an integrated graphics card. My solution for getting at least a basic non-accelerated interface was to edit the xorg config file and add frame buffer 'fbdev' as a device id. It is the same device linux falls back to when I am loading live USB for installation. – nol Feb 16 '17 at 7:36

Following the other instructions here (ppa and install nvidia-367) worked for me but I didn't need integrated graphics or a live CD. This worked for me - I was replacing a GTX 960 with the GTX 1080:

  1. Select one of the recovery entries in GRUB (under advanced)
  2. Select root prompt
  3. Remount filesystem with read/write access: mount -o remount,rw /
  4. Do apt-get purge nvidia-*
  5. reboot
  6. Select your normal Ubuntu entry in GRUB, I was then able to login albeit with a weird resolution
  7. Run the ppa instructions as described in the other answers:

    sudo add-apt-repository ppa:graphics-drivers/ppa
    sudo apt-get update
    sudo apt install nvidia-367
    

Its probably also possible to do it directly in the root prompt if you know how to get the network up.

I had the same problem with my Nvidia GTX 1080 and Ubuntu Budgie 17.04. I have no integtated Graphics available. My LAN is connected via DHCP to the internet.

My walkthrough how I got it running:

  1. Download Ubuntu minimal installer (Link to ubuntu.com) and create a bootable usb stick
  2. Choose "Install ubuntu" when booting from your boot usb stick and follow the instructions of the text installer (in one step you can choose your preferred desktop environment - in my case ubuntu Budgie)
  3. After installing reboot via rescue mode (there's an entry in GRUB)
  4. choose "command line prompt" in the rescue mode menu
  5. Type sudo ip -o link and look what's the name of your ethernet adapter
  6. Type sudo dhclient write-here-name-of-your-ethernet-adapter
  7. Then type sudo add-apt-repository ppa:graphics-drivers/ppa
  8. Then type sudo apt-get update
  9. Then type sudo ubuntu-drivers autoinstall
  10. If everything is installed and you have your command line prompt again, type reboot

Now the X-Server should work as expected with the GTX 1080

I agree with sargunster's method if your CPU comes with the integrated graphic unit.

If you are using Xeon or other systems without other dedicated graphic controller, you can follow my method:

  1. Create a bootable USB loaded with Ubuntu server image.
  2. Install the Ubuntu server. If you cannot boot into the system after the installation (displaying fb characteristic error), you can add nomodeset to the kernel flags.
  3. Once reach the command prompt, login the system and add nvidia proprietary driver repository.

    sudo add-apt-repository ppa:graphics-drivers/ppa

    sudo apt update && sudo apt install nvidia-367

  4. Install Ubuntu or Kubuntu desktop as you wish.

    sudo apt install ubuntu-desktop

    or

    sudo apt install kubuntu-desktop

  5. You will be asked to select display manager between lightdm or sddm. I personally perfer using sddm.

  6. You are allowed to boot into graphical user interface after the reboot.

  • 1
    Could you explain the difference between LightDM or SDDM? (Just a sentence would be enough, maybe with a link for more reading) – Nic Hartley Sep 14 '16 at 2:02

Sounds like to me its a driver issue. Try setting up a live cd and installing nvidia drivers and see if that resolves the issue. Im just guessing at the moment, i would wait for more responses to see if this is a known issue.

link; https://help.ubuntu.com/community/LiveCdRecovery

  • 3
    If you are 'just guessing', it's advised to leave a comment instead of an answer. – grooveplex Jul 6 '16 at 13:06

If you already have an OS Installed and are upgrading to the GTX 1080, you could boot into the OS Using the older gpu (with the 1080 plugged in), and then install the new drivers. No need for a live OS. Worked for me

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt install nvidia-367

The screen turns black because the screen connected to the gpu. Do connect to motherboard before installing the driver. Then, use the nvidia provided download rather than ppa. I solved this issue for my pc, but I don't remember the step correctly.

p/s: You may turn off the intel or anything gpu in the boot. rather than use the nouveau thing.

Not the answer you're looking for? Browse other questions tagged or ask your own question.