Since 2 days ago I can't edit any connections using network manager, because the "edit" button is greyed out. I tried doing a normal restart of the service to no avail.

Any suggestions?


One quick work-around is to invoke the connection editor manually from the command line:


You'll get the same familiar edit screen. Worked for me.

  • 1
    Running nm-connection-editor did it for me. Was all greyed out and empty otherwise. – Thomas Ferris Nicolaisen Jul 10 '15 at 23:54
  • 1
    Running as sudo nm-connection-editor did it for me. – Martin Revert Aug 17 '17 at 8:46
  • Both didn't work. – vineeshvs Sep 7 '19 at 10:38
  • Did not work. Saw the exact same behavior as opening it from the GUI. – JOATMON Nov 23 '19 at 18:14
  • Did work for me but after $ nm-connection-editor cmd. Edit the selected connection and right after run $ sudo /etc/init.d/networking restart – Antonio May 28 '20 at 14:55

Try this fix-for-error-network-device-not i think you got the similar problem as me.

Summary from linked content:

  1. Run in terminal sudo /etc/init.d/networking restart

  2. Edit file /etc/NetworkManager/NetworkManager.conf

  3. Change managed=false to managed=true

  4. Run:

    sudo killall NetworkManager
  5. Now attempt to configure your interface.

  • The first step failed with the following output: stop: Job failed while stopping start: Job is already running: networking – Ann Kilzer Dec 12 '16 at 17:10
  • @AnnKilzer I got the same error, but editing conf and rebooting got it to work. – rrosa Dec 13 '16 at 14:13
  • For me that was not enough. I had to comment all the stuff refering to that interface in /etc/network/interfaces as well – Pablo Jun 17 '17 at 18:37
  • It messed up my network. Now getting the error mentioned in askubuntu.com/questions/755316/… . I had to restart to get a new connection (which happened automatically). – vineeshvs Sep 7 '19 at 10:45
  • Did not work for me. Still grayed out. – JOATMON Nov 23 '19 at 18:39

For NetworkManager to manage an interface, that interface must not be configured under /etc/network/interfaces. Following is my /etc/network/interfaces:

[ubuntu@desktop network] cat interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

Notice that eth0 does not show up; it is managed by NetworkManager. And because of this, it can now be edited with nm-connection-editor, the GUI.

Of course, NetworkManager must be configured to manage your eth0 connection. Follow Sumant's solution on this page on how to configure managed=true (I am not copying his answer because I want to respect his and give credit to where it is due).


It is probably because you did not choose a certificate in the "Wi-Fi Security tab". If you don't have one, mark the checkbox "No CA certificate is required".

  • What? How did you reach that conclusion? You never need to specify a certificate authority for wireless networks with shared-secret encryption or no encryption at all (which is the default and what most people use). – David Foerster Nov 1 '16 at 8:39
  • The input field is mandatory if you don't check the "No CA cert required". I guess there is input validation but no error is shown. It fixed the issue for me in both Ubuntu 16,04 LTS and 14.04 LTS. Don't believe me? Just try it by yourself, as simple as that. – JuanGG Jan 5 '17 at 17:36

After setting up a bridge (e.g. here) the name manager does not show the enslaved interfaces under the 'Ethernet' tab. This is probably normal' yet the "edit connections" turns gray.

This graying out is probably a bug.

Fortunately the actual functionality oft network manager seems to work so you can run nm-connection-editor from the command line to edit the connections using gui or use the command line tool nmcli.

For example to list your connections try:

nmcli con show


u might need to unlock it, there might be an unlock button somweher in that window, if u cant find it try maximising the window and look for it, happened to me once :)

  • 1
    I checked and I don't see there is any unlock button as it is in other configuration options not related to network-manager. I Have done an upgrade and still can edit. – Oscar Martinez Nov 16 '11 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.