6

I'm trying to open GUI apps (gedit/nautilus/firefox) on a 16.04 machine via SSH from a 14.04 machine. The command I use is:

ssh -X username@ipaddress

and then, for example:

nautilus

However, it doesn't open the app and says

Segmentation fault (core dumped)

It doesn't say anything else, just that. Can someone help me resolve this?

4
  • 1
    You need to provide more details. What other error messages do you see? There are a myriad reasons for a segfault.
    – edwinksl
    Jul 6, 2016 at 6:55
  • Edit your question and provide every command related to your issue. Jul 6, 2016 at 17:12
  • @edwinskl, there are no more error messages. Just the segfault. If you can tell me how to get a more verbose message, I can try that.
    – hack777
    Jul 7, 2016 at 7:17
  • sudo apt-get install -y libepoxy-dev
    – Austin
    Jun 10, 2018 at 19:32

2 Answers 2

13

I had the same problem. I ran strace with meld and gedit and it indicated that for some reason there was problem finding libGLX_indirect.so.0 library. I attempted a fix by placing relevant symbolic link inside /usr/lib/x86_64-linux-gnu folder:

sudo ln -s /usr/lib/nvidia-361/libGLX_indirect.so.0

and it works now. Would like to know what is the preferred way of fixing it.

5
  • I had the same problem and it was hard to find on google, thanks for the solution :-)
    – sveri
    Jul 16, 2016 at 9:39
  • I had the same problem with i3wm. After an upgrade (probably nvidia drivers), gnome-terminal would no longer start. Dmesg showed a segfault error 4 in libc-2.23.so. Adding the symlink for libGX_indirect resolved the issue. Thanks! Oct 6, 2016 at 20:05
  • 1
    This solved a ton of issues I had with x2go and generally x-forwarding that I thought were policykit related on an Ubuntu 16.04 machine. In some way, the policykit triggered auth dialog depended on this and then silently failed. It seems like quite a few programs had this dependency, e.g. firefox segfaulted as well without the symlink. Thanks a lot!
    – jmrk84
    Jan 11, 2017 at 23:33
  • 1
    Great this worked. Thanks. PS: For my machine I had to do: sudo ln -s /usr/lib/nvidia-375/libGLX_indirect.so.0 due to different graphics driver versions.
    – vikrantt
    Mar 24, 2017 at 22:28
  • With Bionic Beaver (18.04) there is a default symlink that needs to be overwritten. The command changes to sudo ln -sf /usr/lib/nvidia-387/libGLX_indirect.so.0 Aug 28, 2018 at 18:00
2

The accepted answer works, however according to Launchpad Bugs, the real cause is libepoxy. libepoxy has been fixed since early 2017, but as of June 2017, it is not available as an updated package for 16.04. I followed the instructions by Raj Bhattacharjea to fix this issue. Specifically:

  1. Downloaded the Zesty (17.04) libepoxy for my architecture from https://packages.ubuntu.com/zesty/libs/libepoxy0 (for me it was amd64).
  2. sudo dpkg -i libepoxy0_1.3.1-1ubuntu1_amd64.deb (or your architecture version)

Problem solved. As much as I don't like using a package from another version, this seems like the cleaner solution, especially since I don't have to worry about my link breaking if I change NVidia versions.

Not the answer you're looking for? Browse other questions tagged or ask your own question.