I have a remote server still running Ubuntu 8.10 9.04 that I can only access via SSH.

If I run apt-get update I get a bunch of 404 errors on the packages. I've asked a few questions on Server Fault but got nowhere. Here's what I've done:

  1. Run apt-get update which returns errors like:

    Err http://gb.archive.ubuntu.com intrepid/main Packages 404 Not Found
    [and same for many other packages]

  2. Run do-release-upgrade which returns:

    Checking for a new ubuntu release
    Failed Upgrade tool signature
    Failed Upgrade tool
    Done downloading
    extracting 'jaunty.tar.gz'
    Failed to extract
    Extracting the upgrade failed. There may be a problem with the network or with the server.

  3. Edited /etc/update-manager/release-upgrades and changed from Prompt=normal to Prompt=lts (as suggested here). Running do-release-upgrade after this returns:

    Checking for a new ubuntu release
    current dist not found in meta-release file
    No new release found

  4. (Updated) I have followed the advice in this question and changed /etc/apt/sources.list to refer to jaunty instead of intrepid. However, that distro is not online anymore either. A comment there says I have to upgrade in chronological order...

So basically, it seems like I cannot upgrade because my current distro is out of date and not supported. Is there a way to upgrade direct to 10.x or 11.x? Note, as this is a server I only have command-line access.

UPDATE 24/11: I have managed to upgrade from 8.10 to 9.04. Ubuntu's EOL Upgrades page provides some alternate URLs for apt sources. I also needed to update /var/lib/update-manager/meta-release to point to the old-releases server too.

However, now I cannot upgrade from 9.04 to 9.10. Running do-release-upgrade produces the same error as #2 above, except it "Failed to fetch" (the URLs in meta-release are valid). The Ubuntu Jaunty upgrade page says it's necessary to upgrade using a CD image. I followed the instructions here, but it didn't work:

A fatal error occurred

Please report this as a bug and include the files /var/log/dist-upgrade/main.log and /var/log/dist-upgrade/apt.log in your report. The upgrade is now aborted. Your original sources.list was saved in /etc/apt/sources.list.distUpgrade.

Traceback (most recent call last):

File "/tmp/tmp.JLhTwVUugb/karmic", line 7, in sys.exit(main())

File "/tmp/tmp.JLhTwVUugb/DistUpgradeMain.py", line 132, in main if app.run():

File "/tmp/tmp.JLhTwVUugb/DistUpgradeController.py", line 1590, in run return self.fullUpgrade()

File "/tmp/tmp.JLhTwVUugb/DistUpgradeController.py", line 1506, in fullUpgrade if not self.doPostInitialUpdate():

File "/tmp/tmp.JLhTwVUugb/DistUpgradeController.py", line 762, in doPostInitialUpdate self.quirks.run("PostInitialUpdate")

File "/tmp/tmp.JLhTwVUugb/DistUpgradeQuirks.py", line 83, in run for plugin in self.plugin_manager.get_plugins(condition):

File "/tmp/tmp.JLhTwVUugb/computerjanitor/plugin.py", line 167, in get_plugins filenames = self.get_plugin_files()

File "/tmp/tmp.JLhTwVUugb/computerjanitor/plugin.py", line 120, in get_plugin_files basenames = [x for x in os.listdir(dirname)

OSError: [Errno 2] No such file or directory: './plugins'

It does say to report the bug, but since this is an old unsupported release I don't know if it's worth doing. However, is there a way round this, to upgrade from 9.04 to 9.10 (And then finally to 10.04 LTS.)

  • 1
    possible duplicate of Updating Ubuntu server from 8.10 to 10.04
    – qbi
    Nov 15, 2011 at 17:20
  • @qbi that question doesn't solve the problem because the jaunty repos are no longer available. A comment on that page suggests I must install upgrades in order... Nov 16, 2011 at 10:56
  • 1
    if the server is on a closed network, leave well alone. Its doing a good job :) If you want to use the LTS - back stuff up and go for a clean install. Under no circumstances should you attempt to skip upgrade versions - it will only give you severe headaches.
    – fossfreedom
    Nov 16, 2011 at 11:06
  • @fossfreedom the problem is, I'm having a few problems with some software (webmin) that relies on a few things I am unable to install. Nov 16, 2011 at 12:47
  • ok ... then a fresh install is still my recommendation. For servers I would stick with the LTS releases since you have 5 years support rather than 18months... If you can explain in your question what software you have on the server, maybe someone can point you in the right direction how to migrate data from one software version to the LTS version.
    – fossfreedom
    Nov 16, 2011 at 12:51

3 Answers 3


Update from 'Ubuntu Server 9.04' (Jaunty) to 'Ubuntu Server 10.04 LTS' (Lucid).

based on:



Step 1: install update-manager-core

sudo apt-get update && sudo apt-get upgrade

sudo apt-get install update-manager-core

Step 2: Update from 9.04 (Jaunty) to 9.10 (Karmic)

edit /etc/apt/sources.list to replace "jaunty" with "karmic"

sudo apt-get update
sudo do-release-upgrade

Step 3: Update 9.10 (Karmic) to 10.04 LTS (Lucid)

edit /etc/update-manager/release-upgrades and set Prompt=lts

file should (at minimum) contain:


edit /etc/apt/sources.list to replace "karmic" with "lucid"

sudo apt-get update
sudo do-release-upgrade


To check your server version: (at each stage)

lsb_release -a
  • 1
    Thanks, this is pretty much working spot-on! The only extra thing is when going from karmic to lucid, I needed to change sources.list back to using gb.archive.ubuntu.com instead of old-releases.ubuntu.com. Dec 1, 2011 at 21:08

Download a CD, and do an upgrade install. Definitely do a backup first though!

I would recommend updating to 10.04 (Lucid Lynx) though:

  1. It's a closer upgrade and less likely to explode.

  2. It's an LTS release, and servers that don't get updated often should be running LTS.

The next LTS will be 12.04, but 10.04 will still receive updates for a year after that.

(Edited to correct version number - silly thinko - thanks mikewhatever)

  • 1
    Lucid Lynx is 10.04. :~) Nov 15, 2011 at 20:42
  • 1
    This is a Ubuntu server, with command line only access, so a CD is not an option! Nov 16, 2011 at 10:56
  • Can you connect a CD drive, via USB? Or insert USB stick, with 10.04.3 LTS?
    – david6
    Nov 25, 2011 at 1:52
  • Yes, I believe so, I expect it would be the same as the install instructions for the current release on ubuntu.com. Whether you can boot from USB at all depends on your BIOS/firmware/whatever on your specific machine.
    – ams
    Nov 25, 2011 at 9:24
  • @david6 no, I do not have access to the machine, only via SSH. I thought I made this clear, sorry. Also as noted in the update, I tried to run the CD install by mounting the ISO image but it didn't work. Nov 25, 2011 at 12:44

I had the same problem and I was ble with a small tweak to upgrade "as-usual" my Jaunty (9.04) server and Desktop installations to the latest LTS.

I have put all the details how to do a smooth upgrade from Jaunty to Karmic (even if EOL) in another answer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .