2

From server PC (same pc), I am able to access Apache web server using this link http://192.168.0.21 and virtual host 50000SiteName using this link http://192.168.0.21/50000SiteName

But I am not able to access above links from different Ubuntu pc in LAN.

Similarly I am able to connect to virtual host in dreamweaver from same server PC but not able to connect to that virtual host from different Ubuntu pc in LAN using same settings.

I guess I may need to do some other settings in Apache web server to make this possible but not sure what they are so please let me know what I am missing and what settings I should do.

Below are OS and Web Server details

  • Ubuntu 14.04
  • Apache version 2.4.7

Below code mentioned in etc/apache2/apache2.conf file

  • ServerName 192.168.0.21

Below code mentioned in etc/apache2/port.conf file

  • NameVirtualHost *:80
  • Listen *:80

'50000SiteName' virtualhost is created under Apache web server. and it's config file etc/apache2/sites-avaiable/50000SiteName.conf contains below code.

<VirtualHost *>
    DocumentRoot /var/www/50000SiteName
    ServerName 192.168.0.21
    <Directory /var/www>
        allow from all
        Options None
    </Directory>
    <Directory var/www/50000SiteName>
        allow from all
        AllowOverride All
        Require all granted
        Options None
    </Directory>
</VirtualHost>
1

First from clientPc check if the port 80 is open

nmap -p 80 -PN 192.168.0.21

If it's not open and you're using ufw firewall, allow connections from inside your lan with

sudo ufw allow from 192.168.0.0/24 to any port 80

Test again the port is open

nmap -p 80 -PN 192.168.0.21

Then edit the <Directory> part as follow (it works for me)

<Directory /var/www/50000SiteName>
    AllowOverride All
    Order allow,deny
    allow from all
    Require all granted
</Directory>
  • Ty and I will check all these things and will let you know. – K Ahir Jul 6 '16 at 5:00
  • nmap has given this result: host is up (80/tcp filtered http)... I also made Directory changes mentioned above still not working yet... – K Ahir Jul 6 '16 at 8:25
  • Filtered is not open, did you open the port on ufw? – bistoco Jul 6 '16 at 10:53
  • Check the Directory config again, i made an edit because the / at the begining was missing – bistoco Jul 6 '16 at 10:55
  • I enabled ufw and opened port 80 and 21. Now I am able to connect to Apache server virtual host from other PCs in LAN. But there is one small issue that from other PCs I am not able to add/edit files in website folder in dreamweaver. I guess it is permission related issue but not sure what permissions are needed for it. Can you please advise on this too? Ty – K Ahir Jul 7 '16 at 4:23

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.