12

Actually, I don't know if it's called GNOME Classic. But I don't like the new GNOME (not complaining). I like the version of GNOME that was standard until a few years ago. How can I switch to that in Ubuntu 16.04?

9
  • 1
    You could use MATE, if that's an option. It's a fork of the old Gnome2, and comes with Ubuntu MATE. I'm not sure if Gnome flashback still works these days though, but it should. Mate is more feature-complete than Gnome Flashback, though. – JonasCz Jul 5 '16 at 21:19
  • 2
    It's in the repositories, you can install it with sudo apt-get install ubuntu-mate-desktop. See How do I install MATE (the desktop environment)? – JonasCz Jul 5 '16 at 21:28
  • 3
    You need to choose to start Mate in the login screen - look around, you should be able to choose which "session" to use. Should be under a menu with a gear symbol, but I'm not familiar with Gnome 3. – JonasCz Jul 5 '16 at 21:35
  • 3
    Possible duplicate of How do I install MATE (the desktop environment)? – karel Jul 6 '16 at 0:42
  • 1
    Welcome to AskUbuntu! please don't add the answer to the question -- that's what the answer box is for and self-answers are encouraged – cat Jul 6 '16 at 22:47
9

I don't like the new GNOME

Me too, use mate. =)

Mate is a fork of "the classic gnome".

https://wiki.ubuntuusers.de/MATE/

http://news.tecmint.com/install-mate-1-14-in-ubuntu-mate-16-04-xenial-xerus/

BTW plain debian does not need an external repo for this...

5
  • I tried this: apt-get install ubuntu-mate-desktop. Then rebooted. The login screen is clearly MATE, but once I log in, I'm still running GNOME. – JB_User Jul 5 '16 at 21:49
  • Did you select Mate as session type? – Lord_PedantenStein Jul 5 '16 at 21:53
  • Okay, I got it working. In the upper right hand corner of the top panel, there is an icon that lets you select MATE. MATE is EXACTLY what I was looking for! – JB_User Jul 5 '16 at 21:54
  • 1
    So, is there a way to set MATE as the default so I can set automatic logins and have Ubuntu automatically run MATE? – JB_User Jul 5 '16 at 21:56
  • Honestly i am using fluxbox with light-dm, what login manager are you using? I checked out how to autologin into gdm3 for my htpc running kodi: linuxmintusers.de/index.php?topic=4286.0 – Lord_PedantenStein Jul 5 '16 at 22:26
9

You can use the Gnome Classic that is built into the Gnome DE.

There is no Ubuntu Logo because you are using GDM instead of LightDM.

Just under where you enter your password is a small gear logo.

Clicking on that will give you the option to log into Gnome Classic. It runs on top of your existing Gnome 3 install but includes plugins to make it behave like the old Gnome 2.

If you select Gnome Classic it will become the default DE until you select Gnome again which will log you back into the default Gnome 3 DE.

1
  • It looks like this has been renamed to Gnome Flashback from 16.04(?) - ffonz' answer covers this, you'll need the gnome-session-flashback package installed for it's session item to appear in the Login screen – cleary Feb 19 '18 at 22:14
4

Use Gnome Flashback. Read how to install it from here:

To install the Gnome desktop, press Ctrl + Alt + T to open a Terminal window. Type the following line at the prompt and press Enter. The line is actually two commands. The first command (before the semicolon) updates Ubuntu and the second installs the Gnome desktop.

sudo apt-get update; sudo apt-get install gnome-session-flashback

Click on the system menu in the upper-right corner of the screen and select Log Out to log out of your session.

On the login screen, click the Ubuntu icon.

A list of available desktop environments display. Select the GNOME Flashback option for either Compiz or Metacity.

You are automatically returned to the login screen. Enter your password and press Enter to log in.

Or here. It also works on 16.04.

1
  • This is the actual answer to the OPs question - Gnome Classic, or Gnome Fallback mode is now called Gnome Flashback. It's installable on 18.04 too... – cleary Feb 19 '18 at 22:04
3

Ubuntu MATE can be a option for you, or install the MATE desktop environment.

Ubuntu MATE

MATE desktop envinronment

0
2

The solution is to install MATE:

apt-get install ubuntu-mate-desktop
apt-get install mate

(note that both commands are essential)

then select MATE in the Ubuntu icon on the upper-right corner of the panel at the login screen.

The above worked in Ubuntu 15.10 also.


This answer was extracted from the OP's edit to the question -- please don't add the answer to the question, that's what the self-answer box is for :)

3
  • This can be accomplished in one command as apt-get or apt install accept multiple arguments. apt install ubuntu-mate-desktop mate will suffice. – bschlueter Nov 17 '16 at 6:15
  • @bschlueter I know, I just copied it directly from the question – cat Nov 17 '16 at 15:07
  • Not a critique, I'm just in favor of over informing. – bschlueter Nov 17 '16 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.