I find that often after awakening from suspend on Ubuntu GNOME 16.04 with GNOME 3.20 (I have only found this issue on the latest version, though I have not tried with GNOME 3.18 on 16.04) that I get this strange font issue which can't be fixed by restarting gnome-shell and seemingly only by restarting my entire machine:

gnome-system-monitor font issue

Shutter font issue

File Chooser font issue

Title Bar font issue

gnome-control-center font issue

I do not believe that this is a theme issue as I have tried all the built-in themes (including the dark and light versions) and it is the same for them all. Though it does not seem to affect gnome-shell areas, that is the top-bar, the Activities Overview, etc, are not affected for some reason. So what could this issue be caused by and how can I fix or workaround it?

Information Update:

I have had a look at this answer but the only options in the gnome-tweak-tool for Antialiasing are Rgba, None, and Grayscale, but none of them seem to have any affect on the issue. Is there something I'm missing?

  • 1
    It seems to be a known issue with the Intel drivers. Perhaps you'll find an answer here: askubuntu.com/questions/584922/… – groovy354 Jul 13 '16 at 10:24
  • @groovy354: I have updated my question. – user364819 Jul 13 '16 at 20:27
  • Have you tried that one? askubuntu.com/a/640839 – groovy354 Jul 14 '16 at 5:21
  • Not a solution, but maybe you can just log out to fix it instead of restarting? I have seemingly same issue on Kubuntu 16.04. – Carolus Aug 11 '16 at 18:32
  • Log out does not help, actually this happens to me after switching user and back. Gnome flashback, Ubuntu 16.04. – Ondra Žižka Feb 12 '17 at 2:09

This might be symptom of a kernel bug since 4.4.6, see here which reportedly got fixed in Linux kernel 4.8.x, and the fix will be in Ubuntu 17.04 (which will likely have 4.10 kernel).

On Fedora bug tracker, someone reported that changing / adding this in /etc/X11/xorg.conf.d/20-intel.conf helps:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "blt"
   Option      "TearFree"     "true"

Didn't try, I am going to wait for 17.04.

To me, this happens also after switching to another user account and back.

| improve this answer | |
  • 1
    In 16.04 the Xorg config files are placed in /usr/share/X11/xorg.conf.d. Shouldn't this file be placed there too? – Salem Apr 3 '17 at 18:22
  • 4
    What does the LTS mean, if this fix wont come to 16.04? Such a major issue, and no fix yet to 16.04? Switching to 17.04 is the only solution. Shame on canonical! – ashishsony May 27 '17 at 4:16
  • 1
    @ashishsony The fix is available for 16.04. Just update to a 4.8.x kernel, which is available in official 16.04 repositories. – BingsF Jun 8 '17 at 3:13
  • +1, except that I think the issue started being shipped from kernel 4.4.0 as many people reported in the referenced ticket, instead of 4.4.6. I'm having this issue with 4.4.0-96, on my 14.04 machine. – IsaacS Sep 19 '17 at 13:25
  • Then possibly there are more bugs with these symptomps? Thanks for the info, rewording. – Ondra Žižka Sep 20 '17 at 1:35

When my Ubuntu has display problems when recovering from suspend, I fix it with a quick visit to console: Ctrl+Alt+F1.

Wait a couple of seconds if your display blinks, changes resolution etc. Then back: Ctrl+Alt+F7.

| improve this answer | |

Workaround, use kernel 4.8:

sudo apt install linux-generic-hwe-16.04


| improve this answer | |

I had this problem and discovered that for some reason my laptop was using an old kernel version (4.4, rather than 4.15, currently) .I'm on 18.04, having upgraded from 16.04.

I installed the latest kernel:

sudo apt-get install linux-image-generic

That has fixed the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy