I tried to install winusb in my Ubuntu 16.04 LTS. This is the message I get when I tried to install winusb:

kishoreuk@kishoreuk-HP-Notebook:~$ sudo dpkg -i winusb_1.0.11+saucy1*
[sudo] password for kishoreuk: 
Selecting previously unselected package winusb.
(Reading database ... 172829 files and directories currently installed.)
Preparing to unpack winusb_1.0.11+saucy1_amd64.deb ...
Unpacking winusb (1.0.11+saucy1) ...
Preparing to unpack winusb_1.0.11+saucy1_amd64.deb.1 ...
Unpacking winusb (1.0.11+saucy1) over (1.0.11+saucy1) ...
More than one copy of package winusb has been unpacked
 in this run !  Only configuring it once.
dpkg: dependency problems prevent configuration of winusb:
 winusb depends on libwxbase2.8-0 (>=; however:
  Package libwxbase2.8-0 is not installed.
 winusb depends on libwxgtk2.8-0 (>=; however:
  Package libwxgtk2.8-0 is not installed.

dpkg: error processing package winusb (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:

Please tell me how to install:

  • libwxbase2.8-0

  • libwxgtk2.8-0

  • 2
    I believe WinUSB does not work on / support 16.04 yet. Jul 5, 2016 at 18:33
  • You could try 'sudo apt-get install - f' to install the dependencies you seem to be missing. Jul 5, 2016 at 18:34
  • 1
    @DrA7 Libwx 2.8 is not in the repositories anymore, last version who had them is 15.10
    – Videonauth
    Jul 5, 2016 at 18:39
  • 1
    @JonasCz There is a fork which the WebUpd8 team have added to their PPA which certainly installs well enough on Xenial. I read a few rumbles about usage issues but it seemed ok on my system, especially with gksu installed. Answer added...
    – andrew.46
    Jul 5, 2016 at 21:26
  • 1
    ... or you can use another tool, that works will in all current Ubuntu versions to create a USB installer with Windows 7-10, mkusb at the heading mkusb-nox and mkusb version 12 can create Windows install drives, askubuntu.com/questions/289559/…
    – sudodus
    Sep 26, 2017 at 11:58

5 Answers 5


Indeed techniques for installing WinUSB on older versions of Ubuntu fail on Xenial:

Ask Ubuntu: Can't install WinUSB on Ubuntu 15.10

It may then be worth your while to try a forked build of WinUSB which installs and runs quite nicely on Xenial Xerus. To install and run this without errors you will first need to install gksu:

sudo apt-get install gksu

Then install WinUSB from this PPA (Note that this is not the developer's PPA, this is a PPA from the WebUpd8 team and carries several other non-related packages):

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt update
sudo apt install winusb

A screenshot from my Xenial system following successful installation:

enter image description here


  1. If you havent, install "synaptic package manager" (from ubuntu store/ apps)

Open it and search for

libwxbase3.0-dev right click and "mark for installation"

search for libwxgtk3.0-dev right click and "mark for installation"

Now install by pushing the "apply" button on top

2. Now go to terminal and add the following

sudo add-apt-repository ppa:nilarimogard/webupd8

then do:

sudo apt update

then install:

sudo apt install winusb

For more info on this repo. see: http://www.webupd8.org/2016/06/make-bootable-windows-10-usb-install.html

IMPORTANT NOTE: The developer stated that the graphic-interface (GUI) for winusb is having a bug, which "may" cause to format a wrong disk

Hence it is advised to use terminal/ command line

which is:

sudo winusb --format /path/to/windows.iso device

for example:

sudo winusb --format /home/UserMe/Downloads/win10.iso /dev/sdc

"sdc" here is your device, this may change, easiest way is to open Winusb from apps (gui) and it would display this, SEE in the following example you see our device is /dev/sdb



You need to get the following packages from http://packages.ubuntu.com search for the 15.10 packages and download them for your architecture:


Then you install them with dpkg -i <package name>. If you get error messages about dependencies for one package then remove it with dpkg -r <package name> and install the dependency first then the package again.


Since the time of writing the accepted answer, the fork of WinUSB that works with Xenial has been renamed to woeusb.

So to install it in Xenial, run

sudo add-apt-repository universe
sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install woeusb

And then use command-line interface with woeusb command. Arguments have changed as well:

woeusb --device win7_amd64.iso /dev/sdX

You can compile WinUSB on Ubuntu 16.04.

  1. Grab a source archive from here.

  2. Open a command line (terminal) in the folder you downloaded the archive.

  3. Install required libraries and dependencies: sudo apt install gcc build-essential libwxbase3.0-dev libwxgtk3.0-dev grub-pc-bin

  4. Run the following commands one by one, in the terminal:

tar zxf winusb-1.0.11.tar.gz
cd winusb-1.0.11/src
sed -i -- 's#wxStandardPaths().GetInstallPrefix()#wxStandardPaths::Get().GetInstallPrefix()#g' findFile.cpp
sed -i -- 's#wxStandardPaths().GetDataDir()#wxStandardPaths::Get().GetDataDir()#g' findFile.cpp
cd ..
sudo make install

The above commands patch the code to compile with wxWidgets 3.0, then compile and install the software. You should now have a working WinUSB GUI application. If you launch it from Dash, it should pop up.

However, you may get the 512 error during usage. To prevent this, open /usr/bin/winusb with a text editor with administrator rights (for example pkexec gedit /usr/bin/winusb), find a line that starts with grub-install (line 401) and replace it with:

grub-install --target=i386-pc --boot-directory="$partitionMountPath/boot" "$device"

This is all you need to get WinUSB working on Ubuntu 16.04. You can find more information on my website: Install WinUSB on Ubuntu 16.04 LTS.

Not the answer you're looking for? Browse other questions tagged or ask your own question.