1

The route I went was straight from https://community.linuxmint.com/tutorial/view/1796 website.

Now follow the instructions below:

  1. extract the archive in your Downloads directory (or any other directory).

  2. In terminal run:

cd ~/Downloads/MT7630E-release (change the path if you extracted in another folder)

  1. now run these commands one by one:

sudo chmod +x install sudo ./install

The following is what I did

cd ~/Downloads/MT7630E-release
sudo chmod +x install
sudo ./install

and this is what I got

modprobe: ERROR: could not insert 'mt7630e': Required key not available

I have tried dozens of other methods to get my wifi driver up and running and Im losing patience. I will take any suggestions. Please! Thank you!

  • Try disabling SecureBoot - also look in the "Additional drivers" utility, enabling it may be quite easy, esp. if it worked during the install. Maybe you need to reboot at least once after the install, too. – JonasCz Jul 5 '16 at 14:34
  • ok so i did the SecureBoot. but now it says modprobe: ERROR: could not insert 'mt7630e': Invalid argument – r.newt Jul 5 '16 at 15:45
  • Hmm, In that case, I don't know. Did you look in the "Additional drivers" utility, though ? – JonasCz Jul 5 '16 at 15:48
  • Yes, there was nothing there unfortunately – r.newt Jul 5 '16 at 16:16
  • Please post the output of cat /var/log/kern.log – eyoung100 Jul 5 '16 at 19:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.