0

I've just installed Lubuntu 16.04 on my old HP compaq nc8430 laptop which has ati mobility radeon x1600 graphics card with its own 256MB RAM. Everything went fine apart from the fact that I face severe flickering if resolution is set 1680x1050. This is native resolution of the laptop monitor. There was no flickering before when running win7 on same resolution and there is no flickering on 1280x800 resolution I'm using now to avoid epilepsy seasure :) This fact rules out that something is wrong with the graphics card.

I did a bit of research and these are the other things I've learned/tried:

  1. There is no way to install fglrx drivers on ubuntu 16.04.
  2. I've added GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.dpm=1" as suggested on official site which has maybe helped with heating but it obviously hasn't helped with flickering
  3. There was a suggestion to add new mode to xrandr which I tried, added successfully but flickering remained when switched to that mode xrandr --newmode "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync

Just for the record, when listing xrandr modes only the problematic resolution has a number > 60 (60.11) next to it (which is I presume refresh rate), all other modes have < 60 (59.70-59.98) so this is now my main suspect. Thank for your time and effort, Kanwal

1

I know this is an old post, but it's also the top result on Google for several relevant queries, and there's nothing more frustrating than only finding unanswered questions from other users having the same problem. So in hopes of helping someone who passes by - even if you've given up by now, OP - here's what fixed the horrid screen tearing I experienced on my client's laptop with an X1600 on Linux Mint 18 MATE (solution should apply to any Ubuntu 16.04-based distro including 16.04 itself):

This thread on the Peppermint Linux forums suggests creating a 20-radeon.conf file with the specified parameters. I did so, but left out the DRI line. So, my /usr/share/X11/xorg.conf.d/20-radeon.conf file reads:

Section "Device"
    Identifier "Radeon"
    Driver "radeon"
    Option "AccelMethod" "glamor"
    Option "TearFree" "on"
EndSection

I also removed the 10-amdgpu.conf file that was already in xorg.conf.d. I'm not certain this helped anything, but it didn't hurt, as the amdgpu driver does not and will never support this card. However, inxi -F previously showed both the ati and radeon drivers running for this card, and post-fix only radeon is loaded.

Magic! No nomodeset, no disabled hardware acceleration in browsers or disabling all visual effects in the DE.

| improve this answer | |
  • I tried this with a Ubuntu 17.10 and could not boot. I had to use a rescue boot and remove the lines again to get it up and running. nomodeset works OK. – hschou Nov 27 '17 at 23:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.