5
sudo apt-get install php7.0-curl

screenshot

  • Try sudo apt-get -f install. – anonymous2 Jul 4 '16 at 21:02
  • not working same error message – habibun Jul 4 '16 at 21:07
  • Try @Videonauth's answer. – anonymous2 Jul 4 '16 at 21:07
  • If that doesn't go, you could try a sudo apt-get update; sudo apt-get upgrade. – anonymous2 Jul 4 '16 at 21:09
  • same error not working – habibun Jul 4 '16 at 21:10
6

You can either do:

sudo apt-get install php php-common

or

sudo apt-get -f install

to solve this dependency issue, however, I would opt for the first one, the second is like solving fine details with a sledgehammer.

If this all really doesn't solve your problem, then you might as well check if you have the package repositories enabled

enter image description here enter image description here and run an:

sudo apt-get update
sudo apt-get dist-upgrade

before retrying.


Following procedure retrieved from chat discussion:

wget http://security.ubuntu.com/ubuntu/pool/main/p/php7.0/php7.0-common_7.0.4-7ubuntu2.1_i386.deb
wget http://security.ubuntu.com/ubuntu/pool/main/p/php7.0/php7.0-curl_7.0.4-7ubuntu2.1_i386.deb
sudo dpkg -i php7.0-common_7.0.4-7ubuntu2.1_i386.deb
sudo dpkg -i php7.0-curl_7.0.4-7ubuntu2.1_i386.deb

Solved it. Packages for the 'amd64' architecture can be found at packages.ubuntu.com.

| improve this answer | |
  • Good answer. The advantage of the second one is that it will fix any other problems you have at the same time. – anonymous2 Jul 4 '16 at 21:07
  • If I could +1 more than once... :) Except you keep stealing my thoughts right before I put them down :( – anonymous2 Jul 4 '16 at 21:19
  • Hahaha, well I'm answering right now in between coding on a program, and as soon I get a thought I'll add it :) so simply coincidence – Videonauth Jul 4 '16 at 21:22
  • still same error not working. – habibun Jul 4 '16 at 21:47
  • Try downloading the package here security.ubuntu.com/ubuntu/pool/main/p/php7.0/… and then install it by hand with dpkg -i php7.0-curl_7.0.4-7ubuntu2.1_amd64.deb and let me know if this worked for you. – Videonauth Jul 4 '16 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.