6

I have a Dell PowerEdge T20 microserver running Ubuntu 16.04. Everything is working fine, except that it won't reboot cleanly.

When I issue run the reboot command, the last messages displayed are similar to these:

    [  OK  ] Reached targed Shutdown.
[ 237137.043209] systemd-shutdown[1]: Failed to initialize DM devices, ignoring

I've tried adding the following to /etc/default/grub (and running update-grub and rebooting), but it doesn't help:

GRUB_CMDLINE_LINUX_DEFAULT="reboot=warm,cold,bios,smp,triple,kbd,acpi,efi,pci,force"

The BIOS is up to date (version A06).

Can anyone suggest anything else I can try please?

  • 1
    I think you should use just one of the keyword in reboot --- not all together. In my old Dell desktop, I needed "reboot=bios" (found by trial and error...). Notice that you can check it during interactive boot, see askubuntu.com/questions/19486/… – Rmano Jul 11 '16 at 13:52
2
+100

I recommend working through the reboot= options one by one and testing to see if they work rather than trying them all in one go. The reboot= option takes one of these options at a time, rather than multiple options (for those interested, see reboot_setup() in kernel/reboot.c in the kernel source).

So, try: reboot=warm then reboot=cold then reboot=bios etc in /etc/default/grub (and running update-grub and rebooting then testing the reboot).

In my experience, triple faulting the CPU (reboot=triple) will always reboot an Intel processor and reboot=pci should generally always work too.

  • Ah, I thought more than one option could be specified after reading this blog post: michalorman.com/2013/10/fix-ubuntu-freeze-during-restart I've been working my way through each option in turn, but none of the options seems to fix the problem - it doesn't happen every time, but it's happened at least once with 'triple', 'warm', 'cold', 'bios', 'pci', 'force', 'smp', and 'acpi'. – Luke Girvin Jul 12 '16 at 16:26
1

This implies that there is something wrong on the kernel level, precisely with the device-mapper, and systemd has nothing to do with the error since it shuts down the server fine.

When performing an upcoming reboot; Can you do:

# sync && reboot

And notice how long does it take to see the error message? Does it take around 120 seconds? Or does it appear instantly?

Can you add the below to the kernel parameters, and check what systemd says after a reboot?

systemd.log_level=debug systemd-log_target=kmsg log_buf_len=1M enforcing=0
  • This would be better suited to be put in comments. Until you have enough rep to comment, please stick to concrete questions and answers. – anonymous2 Jul 11 '16 at 15:30
  • It's about 10 seconds between 'reached target shutdown' and 'Failed to initialize DM devices, ignoring'. I added the kernel parameters and rebooted, how do I check systemd? By running journalctl? – Luke Girvin Jul 12 '16 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.