3

After I installed and uninstalled lxde with Ubuntu 16.04, I cannot hear any sound in Ubuntu after logging in with my user (at the login screen, it works).

It started with (from history | grep apt):

  149  sudo apt-get install lubuntu-desktop 
  166  sudo apt install --reinstall ubuntu-desktop
  167  sudo apt install --reinstall ubuntu-desktop && sudo apt install unity
  168  sudo apt lightdm restart
  170  sudo apt autoremove 
  172  sudo apt install --reinstall ubuntu-desktop && sudo apt install unity
  176  sudo apt remove lxde-core 
  177  sudo apt remove lxde-common 
  178  sudo apt autoremove 

And afterwards, the sound was not there anymore (maybe even earlier and I did not recognize).

After some tries (with reboots in between) the sound did not work either:

  194  sudo apt remove alsa-base 
  195  sudo apt autoremove 
  198  sudo apt-get autoremove pulseaudio
  199  sudo apt autoremove 
  202  sudo apt install pulseaudio
  206  sudo apt-get remove alsa
  207  sudo apt autoremove 
  210  sudo apt-get remove alsa-base alsa-utils
  212  sudo apt install indicator-sound
  213  sudo apt-get remove --purge alsa-base
  215  sudo apt-get remove --purge alsa-base
  216  sudo apt-get remove --purge pulseaudio
  217  sudo apt update && sudo apt upgrade
  219  sudo apt-get install alsa-base
  220  sudo apt-get install pulseaudio
  224  sudo apt install indicator-sound

But when I created a new user and logged in as that one, it worked. I've read this article, Sound not working in Ubuntu 14.04 and No sound-indicator after login but did not find any solution for the problem that the sound is only unavailable for one user. It seems like it is a configuration issue of this user. In the home folder, the following configuration files are present:

reichelt@reichelt-Aspire-S3:~$ ll | grep \\.
drwxr-xr-x 28 reichelt reichelt  4096 Jul  4 10:59 ./
drwxr-xr-x  4 root     root      4096 Jul  4 10:48 ../
-rw-------  1 reichelt reichelt 10537 Jul  4 10:48 .bash_history
-rw-r--r--  1 reichelt reichelt   220 Jun  9 20:53 .bash_logout
-rw-r--r--  1 reichelt reichelt  3771 Jun  9 20:53 .bashrc
drwx------ 21 reichelt reichelt  4096 Jul  4 10:21 .cache/
drwx------ 24 reichelt reichelt  4096 Jul  4 10:35 .config/
drwx------  3 root     root      4096 Jul  4 10:21 .dbus/
-rw-r--r--  1 reichelt reichelt    25 Jun 21 00:50 .dmrc
-rw-r--r--  1 reichelt reichelt  8980 Jun  9 20:53 examples.desktop
drwx------  3 reichelt reichelt  4096 Jul  4 10:59 .gconf/
-rw-rw-r--  1 reichelt reichelt   205 Jul  2 15:15 .gitconfig
-rw-r-----  1 reichelt reichelt     0 Jul  4 10:20 .gksu.lock
drwx------  3 reichelt reichelt  4096 Jul  4 10:59 .gnome2/
drwx------  2 reichelt reichelt  4096 Jul  3 17:20 .gnome2_private/
drwx------  3 reichelt reichelt  4096 Jul  4 10:50 .gnupg/
-rw-------  1 reichelt reichelt  6954 Jul  4 10:50 .ICEauthority
drwx------  3 reichelt reichelt  4096 Jun 21 00:50 .local/
drwxrwxr-x  3 reichelt reichelt  4096 Jun 20 23:27 .m2/
-rw-rw-r--  1 reichelt reichelt   402 Jul  3 20:16 missfont.log
drwx------  4 reichelt reichelt  4096 Jun 21 00:50 .mozilla/
drwxrwxr-x  2 reichelt reichelt  4096 Jul  2 15:15 .nano/
drwx------  3 reichelt reichelt  4096 Jun 20 23:29 .pki/
-rw-r--r--  1 reichelt reichelt   675 Jun  9 20:53 .profile
drwx------  6 reichelt reichelt  4096 Jul  4 00:00 .Skype/
drwx------  2 reichelt reichelt  4096 Jun 20 23:44 .ssh/
drwxr-xr-x  3 reichelt reichelt  4096 Jul  2 17:44 .texmf-var/
drwx------  4 reichelt reichelt  4096 Jul  2 10:50 .thunderbird/
drwxr-xr-x  2 reichelt reichelt  4096 Jul  4 10:59 .vim/
-rw-------  1 reichelt reichelt  7900 Jul  4 10:59 .viminfo
-rw-------  1 reichelt reichelt    63 Jul  4 10:50 .Xauthority
-rw-------  1 reichelt reichelt    94 Jul  4 10:50 .xsession-errors
-rw-------  1 reichelt reichelt   829 Jul  4 10:48 .xsession-errors.old

Deleting .config, .gnome2, .gnome2_private and .local and then logging out and back in did not change anything. Has anyone an idea where the wrong configuration may be?

  • did you tried checking levels with alsamixer?, in a terminal alsamixer, left/right arrows to select the item, up/down to change the volume level – bistoco Jul 4 '16 at 9:12
  • I haven't tried it, but unfortunately, this didn't change anything. – David Georg Reichelt Jul 12 '16 at 8:25
  • @DavidGeorgReichelt i have the same problem and creating a new user solved it but as you said what is the cause of the problem in other user? any idea? – Anish Silwal Oct 4 '16 at 15:53
1

I had the same problem yesterday. I installed Jack and after a reboot I encountered this.

After a little searching I came out with this solution.

  1. Uninstall JACK

  2. Go to directory ~/.config/pulse/

  3. Remove all the files located there.

Suddenly, I found my output devices started to show in sound settings.

Hope this helps.

0

I was in the same situation when a new user had sound but I had not after probably screwing something up with apt.

In alsamixer my sound card was displayed, but in settings -> sounds not.

It was solved when I copied (as new user):

/home/newuser/.config/pulse/*

to (as new user; also don't forget to mkdir this):

/home/newuser/pulsecopy/

because the user can't access the other users .config and then to (as original user)

/home/originaluser/.config/pulse/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.