Recently I've notice that my additional drive on my Lubuntu 14.04 works only as read only. I tried a hundred ways to make it mount as rw but nothing. Even sudo seems powerless... Also, that seems to be the case with anything that mounts on the system. From USB Flash drives to internal drives like the one I have for storage.

My setup is that I have an SSD for the OS's and a HDD 1TB NTFS file system for all my files. Also the system is a dual boot with Win 7 on the other side. In the windows partition the drive is working normally.

When I run the following command: sudo mount /dev/sdb1 -o rw I'm getting the error: mount: can't find /dev/sdb1 in /etc/fstab or /etc/mtab However when I checked both files they have the drive listed;

mtab output:

/dev/sda4 / ext4 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
sysfs /sys sysfs rw,noexec,nosuid,nodev 0 0
none /sys/fs/cgroup tmpfs rw 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
udev /dev devtmpfs rw,mode=0755 0 0
devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
tmpfs /run tmpfs rw,noexec,nosuid,size=10%,mode=0755 0 0
none /run/lock tmpfs rw,noexec,nosuid,nodev,size=5242880 0 0
none /run/shm tmpfs rw,nosuid,nodev 0 0
none /run/user tmpfs rw,noexec,nosuid,nodev,size=104857600,mode=0755 0 0
none /sys/fs/pstore pstore rw 0 0
/dev/sda6 /home ext4 rw 0 0
rpc_pipefs /run/rpc_pipefs rpc_pipefs rw 0 0
systemd /sys/fs/cgroup/systemd cgroup rw,noexec,nosuid,nodev,none,name=systemd 0 0
nfsd /proc/fs/nfsd nfsd rw 0 0
/dev/sdb1 /media/alimba/Data ntfs ro,nosuid,nodev,uid=1000,gid=1000,dmask=0077,fmask=0177,uhelper=udisks2 0 0

fstab output:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda4 during installation
UUID=9666a9d5-be93-43af-9cdf-fdb9e5b7fe8c /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=07d1aae9-6d66-4362-95f2-22fbc7e91b37 /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=25e1d371-71b4-46f8-a1e0-569e4ddb77c0 none            swap    sw              0       0

No matter what am I doing the Drive keeps mounting as Read Only, please help...

Thank you...

  • 4
    :confused: I don't see any NTFS drive listed in your /etc/fstab file Jul 3, 2016 at 23:01
  • Welcome to Ask Ubuntu! If it shows in /etc/mtab it means that the system already mounted it. Do not try to mount it again without first unmounting it. Also, why do you use ntfs instead of ntfs-3g? Jul 5, 2016 at 16:20
  • @AndreaLazzarotto Well, in lubuntu 14.04 that was the default, unless I could set it up on installation and missed it...
    – Alimba
    Jul 5, 2016 at 18:41

2 Answers 2



sudo umount /dev/sdb1
mkdir /tmp/MyDrive
sudo mount -o rw /dev/sdb1 /tmp/MyDrive

If it mounts again as read-only, please paste relevant error output from the mount command and relevant dmesg output lines.

To add this partition to your fstab, type: blkid /dev/sdb1 take note of the UUID, then add it to fstab like this:

UUID=<what you got from blkid>  /directory/where/you/want/it/mounted ntfs defaults 0 0
  • The command returned this: sudo mount -o rw /dev/sdb1 /tmp/MyDrive mount: warning: /tmp/MyDrive seems to be mounted read-only. Output of dmesg: [ 10.867037] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131115/nsarguments-95) [ 3911.321384] NTFS driver 2.1.30 [Flags: R/O MODULE]. [ 3911.354126] NTFS volume version 3.1. I also added the lines to the fstab and hopefully after a restart will work...
    – Alimba
    Jul 6, 2016 at 21:13


powercfg /h off

in windows command prompt while shutting down your windows and then try mount again in ubuntu.

  • 1
    Nope... It didn't work... I never used hibernation in Windows but I can understand why you suggested that...
    – Alimba
    Sep 3, 2016 at 21:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .