1

I'm trying to build driver for my WiFi dongle which reports as rtl8191SU, however with no luck as the official drivers from RealTek seems only to go to kernel version 3.0.2, while the current version of my kernel is 3.10...

Moreover this is on arm64 architecture (see Pine 64 project).

The official drivers give multiple errors when compiling e.g.:

field 'xmit_tasklet' has incomplete type

field 'recv_tasklet' has incomplete type

...

which seems to be due to kernel version mismatch.

The driver in question seems to be in fact rtl8712, which is what is downloaded from the realtek website in the end.
Is there some new version of this driver for Ubuntu and newer kernels, or alternative?

1

You might Google rtl8191su. I found a lot of driver hits.

Here's one you might check out...

https://github.com/chunkeey/rtl8192su

Cheers, Al

| improve this answer | |
  • This looks promising, I don't know why my google searches failed me but most of the hits were only forums and non-working crap. Thanks, I will try it out and report back. – Raven Jul 3 '16 at 23:22
  • Please rate my answer by clicking the up arrow shown in my answer. Thanks! Al – heynnema Jul 4 '16 at 13:50
  • Unfortunately I was not able to build this driver because of missing symbol but it doesn't seem like fault of the driver and it may be useful to others. – Raven Jul 4 '16 at 17:54
  • Do you have the Linux header files installed? Can you say what the exact error was? An error, or a warning? Cheers, Al – heynnema Jul 5 '16 at 0:05
  • 1
    I briefly downloaded the driver source, and had the same error messages as you indicate. Time to go back to Google, do a little digging, and find yourself another driver to try. Cheers, Al – heynnema Jul 6 '16 at 5:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.