I have the latest Intel NUC, NUC6i7KYK (specs here), running close to stock Ubuntu 16.04. Its monitor is hooked up via HDMI.

When it wakes up from suspend (S3), it never wakes up the display. The system is up and responsive (I can ssh in), but the display stays off, with no signal. No amount of turning off/on the monitor or unplugging the HDMI cable will restore it.

I tried some of the steps from this guide and found the exact same issue when booted into "runlevel 3", which boots into a console instead of X. (I believe in this case the intel video drivers are still in effect, since the console it boots into is clearly in graphics mode.)

I have not tried hooking up a monitor via DisplayPort because I don't have a capable monitor, so I'm not sure if it's specific to HDMI output or not.

How can I diagnose and fix this issue? Most of the guides I can find are seemingly out of date (e.g. from the article I linked, I can't find the intel_reg_dumper or intel_gpu_dump tools, nor does /proc/acpi/event exist, etc.) or don't go into enough detail (e.g. I was looking at section 3.2.1 of this page, but I have no idea what it means to "set CONFIG_DRM_I915=n").

I had it dump dmesg after waking up. The full output that came after suspending is here, perhaps these two lines might be a clue, if they mean anything to anyone:

[  158.639355] [drm:intel_dp_link_training_clock_recovery [i915_bpo]] *ERROR* failed to enable link training
[  158.647999] [drm:intel_dp_start_link_train [i915_bpo]] *ERROR* failed to start channel equalization

Any help would be appreciated. Thanks!

  • 1
    This might be a quite old post, but I wanted to inform other people who might come here, that this problem is persistent. I have Ubuntu 16.04 and it is full of issues with these NUC machines. Mine, for example, NUC6I7KYK, keeps flickering the monitor connected to the Display Port (if configured at 2K). If you have these machines, do not install Ubuntu! Run away from problems.
    – Ev.
    May 1, 2017 at 7:01

3 Answers 3


Hello I have also a NUC ( but other version ) and I have never have this issue. You can try to see all the errors that you have when the system is start up.

sudo dmesg --level err

Also get information about your graphic card, is your system recognize it?

lspci -vnn | grep VGA -A 12

You can also see the version of your driver

modinfo i915 | grep  verm

mine is : vermagic: 4.15.0-43-generic SMP mod_unload

I recommend you to gather this information to be clear if there are other people with the same problem.

Could you also compare the services you have running before and after suspend ?

systemctl | grep running   > file.txt
systemctl | grep running   > file2.txt
diff file.txt file2.txt

may be you have a clue some of the services are not running.


We have had the same issues with these skull canyon NUC's and a 3 monitor set-up. We had HDMI-HDMI, thunderbolt-HDMI, and DP-HDMI. We put it down to the LG monitors we had but the behaviour was like when you connect to a TV using HDMI and once the monitor doesn't get HDMI signal it just shuts-off. So, yes it is HDMI specific as you say. We resolved this by using converters(and cables) and connecting the monitors using the DVI inputs on the monitors and now the displays don't shutdown.

  • all services working?
    – Abhi4mu
    May 30, 2021 at 4:22

With a suitable cable, you can connect an HDMI monitor to a DisplayPort output and it will work fine. (Note: the other way round will not work.)

Is Ubuntu fully updated?

Is the system firmware fully up-to-date?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .