1

I just clean install Ubuntu 16.04 on my machine, and as usual I set it up to work, installing applications I usually use etc. Then I install Google Chrome, downloading the package from Chrome Download Page, and installed it with gdebi. But when I tried to find chrome from dash, there is no icon of chrome showing up. I tried with sudo apt-get install -f, even sudo apt-get purge google-chrome-stable then reinstall it, and this is what I got:

heno72@thehost79:~/Downloads$ sudo dpkg -i --force-depends google-chrome-stable_current_amd64.deb
Selecting previously unselected package google-chrome-stable.
(Reading database ... 309495 files and directories currently installed.)
Preparing to unpack google-chrome-stable_current_amd64.deb ...
Unpacking google-chrome-stable (51.0.2704.106-1) ...
Setting up google-chrome-stable (51.0.2704.106-1) ...
update-alternatives: using /usr/bin/google-chrome-stable to provide /usr/bin/x-www-browser (x-www-browser) in auto mode
update-alternatives: using /usr/bin/google-chrome-stable to provide /usr/bin/gnome-www-browser (gnome-www-browser) in auto mode
update-alternatives: using /usr/bin/google-chrome-stable to provide /usr/bin/google-chrome (google-chrome) in auto mode
Processing triggers for menu (2.1.47ubuntu1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160523-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...

But still it is not showing up in dash. When I tried Alt+F2 and type google-chrome, it is here, both google-chrome and google-chrome-stable. I do not know what I did wrongly or what the problem is up to now, and I don't even know how to fix it.

Do anyone of you encounter this problem? If so do anyone of you know how to fix it or even what appears to be the problem?

Nb: Apparently chrome didn't even shows up on gnome fallback application list and lubuntu application list (I installed the two alternative desktop just in case unity didn't work or I just need the computer to consume less ram on ram-demanding tasks by switching to either lubuntu or gnome fallback)

Also, possible duplicate, I found this question here. Is it the same problem I have? Because other applications I install from gdebi previously just works and are shown on dash and application lists on other desktop environments, so I think that is not the case. But if it is, please let me know.

Thanks in advance.

  • Why did you have to force-depends in dpkg? – dadexix86 Jul 3 '16 at 15:20
  • @dadexix86 I found the suggestion somewhere in this site, but I forget which answer suggested it (I opened a lot of tabs at the time). But apparently I found a solution for it, I'd put it on an answer. – heno72 Jul 3 '16 at 15:39
1

Open ~/.local/share/applications/google-chrome.desktop in your text editor of choice, and look for this line:

Hidden=true

If it exists, change the line to read:

Hidden=false

Save the file, and Chrome should appear.

0

I tried this answer, and then this one in sequence, then I rebooted just to give them a shot. I do not know how, but it just works for me.

The first answer suggest to install libappindicator1, which at the time apt told me that it had been installed in the latest version on my machine.

heno72@thehost79:~$ sudo apt-get install libappindicator1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libappindicator1 is already the newest version (12.10.1+15.04.20141110-0ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded

Then the second answer suggest to add universe repository then install libgconf2-4 libnss3-1d libxss1. Apparently this is the answer that actually works in my case, as only one out of three packages listed there is not installed in my system (unfortunately I fail to remember which one, nor did I take a screenshot at the time). But I am not entirely sure if this case applied to others who encounter the same problem, so I put both answers here just to be safe.

Now chrome showed up in both Unity Dash, and application lists on Lubuntu and Gnome Fallback.

I wish this answer would help.

0

I have managed to solve the "missing icon" problem by editing:

/usr/share/applications/google-chrome.desktop

There is a line specifying the icon location. I changed it according to location of google chrome icon (I have google-chrome installed in /opt):

Icon=/opt/google/chrome/product_logo_64.png

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.