2

After my latest sudo apt-get upgrade the launcher and the start bar on the left-hand side did no longer appear. Also, the Terminal did not load up when pressing CTRL + ALT + t.

Ubuntu 14.04, 64 bit, desktop/notebook, Unity - with all current updates installed.

Update: The reference from David Foerster here below in the comments contains several fixing approaches. However, I would suggest trying the answer here below first. It seems to be one of the easiest and most reliable, and you don't have to play round with graphic card drivers, the 'Ubuntu Unity Plugin' or setting up temporary display variables.

  • 2
    Possible duplicate of Unity doesn't load, no Launcher, no Dash appears – David Foerster Jul 3 '16 at 12:02
  • David Foerster - the link you have posted is the link that I put in as my reference for the suggested fix 1 and 2. Further down on that page, the rm compiz fix is mentioned too. The intention my post is to make it much clearer for the reader to find the probably fastest solution without creating much work and not messing around with ccsm or graphic card drivers, as suggested in other posts. – johann_ka Jul 3 '16 at 12:50
  • You seem to assume that these symptoms always have the same cause, which is obviously not true if you look at the answers of the linked question. Rather than creating new questions you should add your answer to the duplicated question unless you can make your argument that the premise of your question is somehow different. – David Foerster Jul 3 '16 at 14:55
1

The fix that worked for me right away was:

Start your machine and log in. Then change to tty1 by pressing Ctrl+Alt+F1 and log in on tty1. Then enter sudo rm -rf ~/.config

Then restart your computer by entering sudo reboot.

Additional information: sudo rm -rf ~/.config deletes and thus resets your display settings and your audio settings, e.g. remove icons from your launch bar that are not default icons or unmute system sounds if you muted them beforehand. However, your installed software etc. remains untouched and unchanged. Check itsfoss.com for more information

The often recommended fixes did NOT work for me (source):

Suggested fix 1:

Change to tty1 by pressing Ctrl+Alt+F1 and log in.

export DISPLAY=:0
dconf reset -f /org/compiz/
setsid unity

Suggested fix 2:

Change to tty1 by pressing Ctrl+Alt+F1 and log in.

sudo apt-get install compizconfig-settings-manager
export DISPLAY=:0
ccsm &

Press Ctrl+Alt+F7 (or Ctrl+Alt+F8 sometimes) to get back to the graphical display where there should be a CompizConfig Settings Manager screen sitting there. Find the plugin 'Ubuntu Unity Plugin' and enable it.

I hope this makes is easier to find a possible fix for those who are experiencing the same issue as I had.

Best, J

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.