3

So I just installed Ubuntu 16.04 on my Dell XPS 13. When I get to the login screen it starts at 3200x1800 for a quick second, then I get a way lower resolution like 800x600 but as soon as I login it adjusts to 3200x1800. How would I get 3200x1800 permanently on my login screen? I didn't have this issue on 14.04.

2

force your desired resolution in grub

sudo nano /etc/default/grub

Find this line

#GRUB_GFXMODE=640x480

change it to

GRUB_GFXMODE=3200x1800

then rebuild the frames and update grub

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
sudo update-initramfs -u
sudo update-grub

tell us if this worked.

**EDIT:

if the problem is about the login screen resolution only, read here

0

Hiting ESC in GRUB and entering videoinfo showed that GRUB doesn't support all the screen resolutions available in gnome-control-center display so I used a workaround from this answer:

sudo cp .config/monitors.xml /var/lib/gdm3/.config/

Reboot to see the effect

This workaround was tested in Ubuntu 18.04 if you use version 17.04 or lower (LightDM) either upgrade to version 17.10 or above or install gdm3 sudo apt install gdm3 select your preferred resolution in gnome-control-center display then sudo dpkg-reconfigure gdm3

Select gdm3 if prompeted copy monitors.xml as shown above then reboot

0

FOR Q4OS ONLY Not Ubuntu, Although... Could be Similar.

I Search all over, and nothing worked. And then I thought how I saw two connected monitors using the command "xrandr -q". And I thought how about Unified Outputs(Both Screens being the same, like a mirror setting.) I definitely had one screen connected. My issue was that Q4OS asked me to select my Monitor setup when I first install, but I didnt answer it at the login screen, I answered it after, when it asked again. AND I didnt want to reinstall Q4OS so I check the display settings and attempted to change the resolution of the second monitor, And I saw the second monitor was disabled(But xrandr -q told connected) with a max resolution of 1024x, AND I know I had LVDS (all-in-one PC screen Capability) disabled in bios, so I went to BIOs and enabled the LVDS setting in my BIOs video. And when I booted up the Login Screen was full 1920X1080, already. When I logged in, the main screen was wrong, so I saw nothing, no dock. I had to right click and then run a command, and then type display and then click unified outputs or merge the two monitors dragging them to each other with mouse(or just click Unified Outputs). As soon as you see the OS GUI Graphic Monitor output setup graphic prompt, click unified outputs, the two screens with same desktop, or else it wont save, when restarted. Probably only for Q4OS.

My Fix Run Down:

Terminal and then type command "xrandr -q"

Look for more then one Connected Monitor outputs Mine was HDMI and DP.

If more then one Continue to read further.

*Right click on desktop > Run a Command > Type "Display" > Find "Displays" from the drop down menu.

*Now you should see two boxes indicating monitors. You can either drag one monitor to the other one merging OR you can simply Click "Unified Outputs" right under it, second button over from the right side. IF THE RESOLUTION HAS A MAX LESS THAN THE MAIN DISPLAY continue reading.

*Check if you have LVDS or any built in Screen system > Go to bios and enable this for Resolution support! > Once enabled > Boot OS.

*With the new login resolution already fixed by the enabling of LVDS.

*Log into the OS, and then you might have to right click > run command > type "display" and do that setup we did prior.

*When the screens are unified once again, you should see the OS GUI Graphical Setting prompt, NEEDED Quickly select "Unified Outputs" (Two monitors with the same desktop), dont let it fade away or you'll have to reboot again and right click and command and then display settings all over again.

I hope this helped someone!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.