9

I'm trying to set up localhost with these instructions

Now at step 11 I'm supposed to open nautilus in terminal but whatever I do it throws some error at me.

I tried reinstall and update nautilus with no luck; the same errors appear after using sudo nautilus.

This is what the error looks like.

(nautilus:4594): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
(nautilus:4594): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
(nautilus:4594): Gtk-CRITICAL **: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
(nautilus:4594): GLib-GObject-WARNING **: invalid (NULL) pointer instance
(nautilus:4594): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

I'm new to Linux and Ubuntu. I tried to google for the errors but without luck.

In Ubuntu I only replaced gnome network with wicd network manager

thanks in advance for any suggestions or help

Ivo

4
12

These are not errors. These are warnings and all warnings are to be ignored.

With that said, you should use sudo -i to run gtk applications with sudo.

sudo -i nautilus

These warnings are normal and are to be ignored safely.

Although a fix is not necessary, there is a workaround.

The only work around requires you install the development files:

sudo apt-get update
sudo apt-get install libgdk-pixbuf2.0-dev
sudo gdk-pixbuf-query-loaders --update-cache
sudo killall nautilus

That should take care of most of the warnings.

If you don't like to see output in the terminal after running the command, you can use the nohup command like so:

nohup sudo -i nautilus

or

nohup sudo -i nautilus &

Again, in the future, you can ignore warnings like these unless there is a problem running the application.

2
  • 1
    sudo -i nautilus will give me warning again , while doing it with gksu nautilus it works without a hitch . (nautilus:3310): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed this is after doing all the updates that you posted Jul 3 '16 at 13:08
  • @IvoOlivieri That's just because gksu is non-verbose. Are you using ssh? If you are using ssh, sometimes you have to kill nautilus on the remote computer before using ssh to start nautilus.
    – mchid
    Apr 22 '17 at 22:42
0

I found these warnings super annoying and didn't want to install multiple packages just to fix them. You can swallow command output by redirecting to a file:

nautilus ./myDirectory &> /dev/null

This would get really annoying to write every time, so I created a custom function in ~/.bashrc:

 function naut() { 
    nautilus "$@" &> /dev/null 
 } 

Which you can then use like so:

naut ~/Desktop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.