1

I'm trying to install kjots in ubuntu 16.04 and looks like the package is not available in ubuntu 16.04.

$ sudo apt-get install -s kjots
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package kjots is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  kdepim-doc

E: Package 'kjots' has no installation candidate

Anyone has any idea on how to install it ?

Enabled universe vivid repo, but still no luck.

$ sudo apt-get install kjots
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kjots : Depends: libkdepim4 (= 4:4.14.6-0ubuntu1) but it is not going to be installed
         Depends: libnoteshared4 (= 4:4.14.6-0ubuntu1) but it is not going to be installed
 libpimcommon4 : Depends: libkdepim4 (= 4:4.14.6-0ubuntu1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Looks like kjots is not ported to kdepim: https://launchpad.net/ubuntu/+source/kdepim

However, I found the source package of Kjots in github: https://github.com/KDE/kjots

Anyone has any idea on installing the same from source package?

  • Not sure if this is related but if I apt-cache search kjots i get the following output gjots2 - Simple jotter (outline processor) for X11/gtk-gnome. If this solves it I will move it to an answer so you can accept it. – Videonauth Jul 1 '16 at 22:27
  • CherryTree looks like a decent replacement for the defunct kjots, I can write this up if you are interested? giuspen.com/cherrytree – andrew.46 Jul 2 '16 at 4:55
  • actually, I want kjots because i have used it before and want to migrate my old books. so I think it only works in kjots. – Vipin Ms Jul 3 '16 at 6:12
0

This means you perhaps don't have the correct repository open.

sudo gedit /etc/apt/sources.list

If universe is not included then modify the file so that it does.

deb http://archive.ubuntu.com/ubuntu xenial universe multiverse

then try installing.

sudo apt-get update && sudo apt-get install kjots
  • 1
    Shouldn't that not be xenial instead of vivid? The OP is using 16.04. – Videonauth Jul 1 '16 at 22:44
  • You're absolutely right. – amrx Jul 1 '16 at 22:51
  • @Videonauth But there is no installation candidate for Ubuntu 16.04. If OP must get kjots, he/she will have to deal with installing from a 14.04 repo. – edwinksl Jul 1 '16 at 22:54
  • But then still better downloading it as deb file from packages.ubuntu.com as doing a repo hack. – Videonauth Jul 1 '16 at 23:04
  • universe is already enabled, i have enabled vivid is also but it is not working – Vipin Ms Jul 3 '16 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.