4

I have a new Ubuntu 12.04 that's not connected to the internet. So I download .deb files into my phone and send it to my PC via USB cable.

But the dependencies that are required are giving me a real headache.

Take Aircrack as an example. When you try to install the package, it says

Dependency is not satisfiable: iw

Then after downloading and opening iw, it gives

Dependency is not satisfiable:  libnl-3-200 (>=3.2.7)

I get the following error when I try to install those packages with Software Center:

Dependency is not satisfiable: [DEPENDENCY_NAME] [DEPENDENCY_VERSION]

So, I was wondering if there is some way to download all the dependencies together with the package.

Thanks in advance.

  • What error messages do you see? Can you include that as part of your question? – edwinksl Jul 1 '16 at 13:54
  • Dependency is not satisfiable: [DEPENDENCY_NAME] [DEPENDENCY_VERSION]. – Slim Shady Jul 1 '16 at 13:59
  • Copy and paste all that into your question and give more details if you can. Your question is currently too vague. – edwinksl Jul 1 '16 at 14:00
  • See the edited question – Slim Shady Jul 1 '16 at 14:10
1

If you can download the .deb files to your phone, and transfer them to the computer via USB cable, you can use tethering to let Ubuntu download directly using the same data connection your phone uses to download the .deb package files. Then dependencies will be automatically filled.

The downside of this is that you'll use (a little) more cellular data -- the upside is that you'll save loads of time and you can be sure stuff is working while your computer is (temporarily) connected to the Internet.

| improve this answer | |
  • I was suggesting you tether through the USB cable. – Zeiss Ikon Jul 1 '16 at 16:05
  • that's what I did. I tried it before and It was working perfectly, but now no WiFi or tether icon and no internet access – Slim Shady Jul 1 '16 at 16:07
  • @BenJunior sudo service network-manager start – mchid Jul 1 '16 at 20:55
  • sounds like you should solve this network problem instead of trying to work offline – Bhikkhu Subhuti Jul 1 '16 at 21:06
  • hey guys, I found out that wlan0 isn't listed in the ifconfig command. i tried ifconfig wlan0 up but no such device. and I don't know what it really us but mon0 isn't also listed – Slim Shady Jul 3 '16 at 9:34
1

Find another system that has 12.04 and then install everything you want using synaptic or app store, (or terminal). Then copy all of the files you find in (root)/var/cache/apt and to your machine in the same directory (with root access). You still might need to have an updated cache, but all heavy downloading should be finished with this method. Do not copy the lock file.. and it won't let you anyways.

I usually type (you might type nautilus instead of caja for ubuntu) to launch a gui file manager with su privs. It is dangerous, but terminal can be more dangerous. Close it when you are done.

gksu caja

The next methodenter image description here

The next method.. I think I tested this.. You still need a live machine. You can use a persistent thumbdrive on any friend's computer. same version same bits. I ran this once and it worked. I mostly use the first method. Follow this link to odzangba

Like the other person said, you can use your cell phone as a tether and get a network connection (even by usb cable). Give it a try. For the big downloads, go to starbucks or a free wifi hotspot.

| improve this answer | |
0

All newer versions of ubuntu have iw installed by default. Install a newer version to avoid such a headache.

Also, you can go to http://packages.ubuntu.com where you can see a list of dependencies for each package you select.

You can use the command dpkg -l | grep packagename to search for installed packages. example:

dpkg -l | grep iw

If you connect to the internet and use apt-get to do the install, it will automatically satisfy all dependencies for you.

I suggest you connect to the internet.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.