5

I am trying to rotate a dual monitor which is attached to the VGA output of my laptop. My system is Ubuntu 15.10.

However, here is the outcome I get when I use xrandr:

xrandr --output VGA-1-0 --rotate right
xrandr: output VGA-1-0 cannot use rotation "right" reflection "none"

I have seen other posts on this subject, which all recommend editing xorg.conf. I have tried that, too. Here's my current xorg.conf file:

Section "ServerLayout"
Identifier "layout"
Screen 0 "nvidia"
Inactive "intel"
EndSection

Section "Device"
Identifier "intel"
Driver "modesetting"
BusID "PCI:0@0:2:0"
Option "AccelMethod" "None"
Option "RandRRotation" "True"
EndSection

Section "Screen"
Identifier "intel"
Device "intel"
EndSection

Section "Device"
Identifier "nvidia"
Driver "nvidia"
BusID "PCI:1@0:0:0"
Option "ConstrainCursor" "off"
Option "RandRRotation" "True"
EndSection

Section "Screen"
Identifier "nvidia"
Device "nvidia"
Option "AllowEmptyInitialConfiguration" "on"
Option "IgnoreDisplayDevices" "CRT"
Option "RandRRotation" "True"
EndSection

Still, I keep getting the same error when trying to use xrandr to rotate that screen.

Is there another way of doing so?

5
  • I find the easiest way to manage screen rotation/placement/resolution is by using the arandr GUI. You can then save the file in arandr and it will be some xrandr commands that you can look at or save such that it does so on login.
    – nixpower
    Jul 1 '16 at 13:10
  • 1
    Yes, I have tried using arandr, too. When I right-click over the dual monitor screen, all options under "Orientation" are disabled, except for "normal", which is selected.
    – user809418
    Jul 1 '16 at 13:14
  • I have exactly the same issue!! Jul 25 '16 at 14:01
  • What is your GPU? What is the exact name of your dual monitor? Please, provide them to the end of your body. Jul 25 '16 at 14:18
  • Apparently this is because Canonical patched X so that the nvidia driver can't rotate the screen. devtalk.nvidia.com/default/topic/999654/linux/…
    – Max N
    Aug 14 '17 at 23:21
1

Timo Aaltonen has fixed this issue! Update your xorg-server. Thank you.

xorg-server update

0

(EOL of 15.10 expires today! I hope this helps!)

There is an old app (2012) that did the trick for me in my previous laptop. It is called Magick Rotation. Fint the latest .deb file here. Note, apparently it only works for Lenovo, Dell, Fujitsu, and HP. To install, do as usual:

sudo dpkg -i file.deb
sudo apt-get install -f 

The app has a nice GUI, that you can see below:

enter image description here

Note: since this is an old app, some old dependencies might be needed. Be careful!

In the Advanced Setup menu you can setup the onboard keyboard to run after rotation. It is very likely you will not have CellWriter (the default), as it is not shipped with 14.04 and newer ubuntus. In your case, this keyboard must be onboard. Change accordingly (see onboard --help for the full range of options).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.