3

Some applications don't appear in Applications menu MATE Desktop Environment. For instance, I would expect Chromium to show up under Internet... but it doesn't.

MATE Applications menu

I've checked all categories and tried this which gave me the following outputs:

$ desktop-file-validate .local/share/applications/*.desktop
.local/share/applications/chromium-browser.desktop: warning: key "Encoding" in group "Desktop Entry" is deprecated
.local/share/applications/_opt_sublime_text_sublime_text.desktop: warning: key "Encoding" in group "Desktop Entry" is deprecated
.local/share/applications/sublime_text.desktop: warning: key "Encoding" in group "Desktop Entry" is deprecated
.local/share/applications/sublime_text.desktop: error: (will be fatal in the future): value "sublime_text.png" for key "Icon" in group "Desktop Entry" is an icon name with an extension, but there should be no extension as described in the Icon Theme Specification if the value is not an absolute path

and

$ desktop-file-validate .gnome/apps/*.desktop
(no output)

and

$ desktop-file-validate /usr/share/applications/*.desktop

Outputs this

I can't also find Sublime Text under the category Programming, but LibreOffice Math is listed under Education.

How do I fix this and make Sublime Text, Chromium and other applications show up in the right category? I would prefer an automated solution for all applications, but a solution to specifically fix Sublime Text and Chromium would okay if no such automated solution exists.

Update

I've installed alacarte, and run it with gsku alacarte (I found that running alacarte with normal priviliges doesn't even show all applications in Main Menu). I see that Chromium and Sublime Text are checked, and even are in the right categories, but they still don't show up in the Applications menu.

  • Weird! on my system alacarte doesn't exist... the menu editor I get with right click on applications can also be accessed via Control Centre > Look & Feel > Main Menu. Do you have anything there? – Zanna Jul 1 '16 at 13:32
  • @Zanna yup, I see it! But it still won't work. I can delete items but not add new ones. – grooveplex Jul 1 '16 at 13:47
  • I have also discovered that changing the menu options doesn't change .desktop files in /usr/share/applications (most don't have entries in ~/.local)... still investigating! – Zanna Jul 1 '16 at 14:38
  • Looking at the errors from desktop-file-validate in ~/.local... seems those .desktop files have fatal errors and need to be edited. If you post the contents of the files, we can figure out how to fix them. – Zanna Jul 2 '16 at 8:11
2

Right click the menu button and you can edit the menus to choose which installed applications appear. I had a similar problem & was surprised by the simplicity of the solution!

If you don't see the option, you first need to

sudo apt-get install alacarte

If Edit Menu isn't visible, do Alt+F2 and type alacarte.

  • Thanks for your answer, but I don't see the 'Edit' option – grooveplex Jul 1 '16 at 11:58
  • I found I have to install alacarte (source: ubuntuforums.org/showthread.php?t=2143361). I'll now log out and log in and see what happens. – grooveplex Jul 1 '16 at 12:07
  • I've logged out and logged in, but I still can't see the option. I'm rebooting now. – grooveplex Jul 1 '16 at 12:10
  • See updated question – grooveplex Jul 1 '16 at 13:01
  • @grooveplex well that's very nice of you but I don't think your question was unanswerable (some tweaking of the .desktop files would have fixed it I believe... Still, thanks! – Zanna Jul 8 '16 at 8:38
0

For alacarte to work, I had to use a 128x128 jpg. (Open the icon in kolourpaint, resize it (Menu-Image-Resize) to 128x128 and save as jpg.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.