3

Recently I installed gnome-desktop in my Unity Ubuntu 16.04.Now I want to set my Unity desktop environment as default.

I installed Gnome by using these commands :

sudo apt-get install ubuntu-gnome-desktop

then chose gdm3 as default.

Now, I have searched on internet how to do so, one of them say this :

sudo /usr/lib/lightdm/lightdm-set-defaults -s ubuntu

But it throws error saying :

sudo: /usr/lib/lightdm/lightdm-set-defaults: command not found

I'm using ubuntu 16.04.

2
  • 1
    You don't have to do that. Lightdm, or whatever is used, should remember the last option selected. Select Unity at login once, and Unity will be the default, until another option is selected. – mikewhatever Jul 1 '16 at 9:58
  • If you dont want gnome follow this steps and then restart the pc. askubuntu.com/a/767582 – dhrumit patel Jul 29 '19 at 15:55
4

Add the following line to /etc/lightdm/lightdm.conf file ( if it doesn't exist - create it. File must be owned by root )

[SeatDefaults]
user-session=unity

That will make unity default for all users, but remember what mikewhatever said: if you choose a specific session once, login screen will remember it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.