1

So I finally dual booted Windows 10 with Ubuntu 16.04. I have been running Xubuntu on my secondary laptop around 5-6 months and now decided to install it on my main laptop so far Ubuntu runs great but there's only one issue: I can't see my dedicated GPU [AMD Radeon 8670M] it only shows my Intel Integrated GPU [Intel HD Graphics 4400]. On Additional drivers section there are only Intel Proprietary Drivers.

Here are the Commands I ran :

$ sudo lshw -c video

 *-display               
       description: VGA compatible controller
       product: Haswell-ULT Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:44 memory:c2000000-c23fffff memory:b0000000-bfffffff ioport:6000(size=64)**

and

$ lspci -nn | grep VGA

00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09)

and

$ dmesg | egrep "radeon|drm"

[    1.345817] [drm] Initialized drm 1.1.0 20060810
[    1.386931] [drm] Memory usable by graphics device = 2048M
[    1.386937] fb: switching to inteldrmfb from VESA VGA
[    1.387046] [drm] Replacing VGA console driver
[    1.391211] [drm] radeon kernel modesetting enabled.
[    1.395226] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    1.395229] [drm] Driver supports precise vblank timestamp query.
[    1.398577] radeon 0000:0a:00.0: enabling device (0006 -> 0007)
[    1.424927] [drm] Initialized i915 1.6.0 20151010 for 0000:00:02.0 on minor 0
[    1.425088] [drm] initializing kernel modesetting (HAINAN 0x1002:0x6660 0x103C:0x2164).
[    1.425101] [drm] register mmio base: 0xC2400000
[    1.425102] [drm] register mmio size: 262144
[    1.429954] radeon 0000:0a:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
[    1.429956] radeon 0000:0a:00.0: GTT: 2048M 0x0000000040000000 - 0x00000000BFFFFFFF
[    1.429957] [drm] Detected VRAM RAM=1024M, BAR=256M
[    1.429958] [drm] RAM width 64bits DDR
[    1.430106] [drm] radeon: 1024M of VRAM memory ready
[    1.430107] [drm] radeon: 2048M of GTT memory ready.
[    1.430116] [drm] Loading hainan Microcode
[    1.430197] [drm] Internal thermal controller without fan control
[    1.430254] [drm] probing gen 2 caps for device 8086:9c18 = 5323c42/0
[    1.438512] [drm] radeon: dpm initialized
[    1.438518] [drm] GART: num cpu pages 524288, num gpu pages 524288
[    1.439806] [drm] probing gen 2 caps for device 8086:9c18 = 5323c42/0
[    1.439810] [drm] PCIE gen 2 link speeds already enabled
[    1.442772] [drm] PCIE GART of 2048M enabled (table at 0x0000000000040000).
[    1.442964] radeon 0000:0a:00.0: WB enabled
[    1.442967] radeon 0000:0a:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0xffff8800355bec00
[    1.442968] radeon 0000:0a:00.0: fence driver on ring 1 use gpu addr 0x0000000040000c04 and cpu addr 0xffff8800355bec04
[    1.442970] radeon 0000:0a:00.0: fence driver on ring 2 use gpu addr 0x0000000040000c08 and cpu addr 0xffff8800355bec08
[    1.442971] radeon 0000:0a:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0xffff8800355bec0c
[    1.442973] radeon 0000:0a:00.0: fence driver on ring 4 use gpu addr 0x0000000040000c10 and cpu addr 0xffff8800355bec10
[    1.442974] radeon 0000:0a:00.0: VCE init error (-22).
[    1.442976] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    1.442977] [drm] Driver supports precise vblank timestamp query.
[    1.442979] radeon 0000:0a:00.0: radeon: MSI limited to 32-bit
[    1.443009] radeon 0000:0a:00.0: radeon: using MSI.
[    1.443040] [drm] radeon: irq initialized.
[    1.551879] fbcon: inteldrmfb (fb0) is primary device
[    1.551995] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    1.680395] [drm] ring test on 0 succeeded in 1 usecs
[    1.680403] [drm] ring test on 1 succeeded in 1 usecs
[    1.680419] [drm] ring test on 2 succeeded in 0 usecs
[    1.680428] [drm] ring test on 3 succeeded in 4 usecs
[    1.680436] [drm] ring test on 4 succeeded in 4 usecs
[    1.680715] [drm] ib test on ring 0 succeeded in 0 usecs
[    1.680744] [drm] ib test on ring 1 succeeded in 0 usecs
[    1.680771] [drm] ib test on ring 2 succeeded in 0 usecs
[    1.680792] [drm] ib test on ring 3 succeeded in 0 usecs
[    1.680813] [drm] ib test on ring 4 succeeded in 0 usecs
[    1.681381] [drm] Radeon Display Connectors
[    1.682905] [drm] Initialized radeon 2.43.0 20080528 for 0000:0a:00.0 on minor 1
[   21.205885] [drm] probing gen 2 caps for device 8086:9c18 = 5323c42/0
[   21.205890] [drm] PCIE gen 2 link speeds already enabled
[   21.212077] [drm] PCIE GART of 2048M enabled (table at 0x0000000000040000).
[   21.212176] radeon 0000:0a:00.0: WB enabled
[   21.212178] radeon 0000:0a:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0xffff8800355bec00
[   21.212180] radeon 0000:0a:00.0: fence driver on ring 1 use gpu addr 0x0000000040000c04 and cpu addr 0xffff8800355bec04
[   21.212181] radeon 0000:0a:00.0: fence driver on ring 2 use gpu addr 0x0000000040000c08 and cpu addr 0xffff8800355bec08
[   21.212183] radeon 0000:0a:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0xffff8800355bec0c
[   21.212184] radeon 0000:0a:00.0: fence driver on ring 4 use gpu addr 0x0000000040000c10 and cpu addr 0xffff8800355bec10
[   21.212186] radeon 0000:0a:00.0: VCE init error (-22).
[   21.448861] [drm] ring test on 0 succeeded in 1 usecs
[   21.448866] [drm] ring test on 1 succeeded in 1 usecs
[   21.448872] [drm] ring test on 2 succeeded in 1 usecs
[   21.448880] [drm] ring test on 3 succeeded in 4 usecs
[   21.448887] [drm] ring test on 4 succeeded in 4 usecs
[   21.448951] [drm] ib test on ring 0 succeeded in 0 usecs
[   21.449007] [drm] ib test on ring 1 succeeded in 0 usecs
[   21.449062] [drm] ib test on ring 2 succeeded in 0 usecs
[   21.449076] [drm] ib test on ring 3 succeeded in 0 usecs
[   21.449090] [drm] ib test on ring 4 succeeded in 0 usecs

EDIT: Formatting

  • If the computer doesn't find the device on its PCI bus this issue is unrelated to Ubuntu. Either the device is not connected or broken. – David Foerster Jul 1 '16 at 8:31
  • But it works fine on Windows 10 - i.imgur.com/b6Zgic2.png – bitz2110 Jul 1 '16 at 9:15
  • Please edit your question and add output of lspci terminal command. Please do not post pictures, post text. – Pilot6 Jul 1 '16 at 9:16
  • Try running sudo apt-get install amd64-microcore. Then go to proprietary drivers window and see what comes up. – user308164 Aug 3 '16 at 7:32
0

computer see card but is switching from card to integrated graphics,for some reason..note a line →

" switching to inteldrmfb from VESA VGA "

So further steps are obvious,look on this site or else for →How to switch from integrated graphics to dedicated graphics. There are commands for that. And "lspci" command can confirm that card is seen. Waiting for confirmation of "that card is seen" with output of command " lspci | grep VGA " (type in terminal one or both lspci commands without ")and post results here.

  • Is this an answer or a comment? Hard to tell. Can you please clarify. – user308164 Aug 3 '16 at 7:32
  • if you read is comment as he already post output from what is seen that system use integrated graphics ,and not dedicated,and also is solution ,to point user in which direction to solve problem,as dedicated graphics is seen from system,and how to switch to dedicated graphic is explain so many times on this site..and command is there just that he can confirm that to yourself and others... – siniša Dec 18 '16 at 5:29
0

If you install ubuntu when primary graphics was integrated graphics(in your case intel) ,then ubuntu load drivers for that..so you need to check and switch in BIOS that primary graphics system will use is AMD ..and then boot ubuntu.. Ubuntu will then boot with dedicated graphics,and use open source drivers, and once is booted you can chose to use open source drivers,or to install closed source(proprietary amd driver) please note from ubuntu 16.04 ubuntu will not allow to use proprietary amd driver fglrx for older cards which fall in legacy..(your card is not in that group,but you are not only reading this) and second note: when you boot in ubuntu ,go click on your user name on top right,and coose "about computer" and then new widow will open where you can read,name of computer,memory,processor ,and gaphics used..so in line where is graphics mentioned ,check that is graphics card used what you wanted,BUT if in line is mentioned "pipe"..you will need to reboot one more time ,and same is valid if you boot from recovery mode,as 1st time ubuntu can boot to low level of graphics,and after send boot(or reboot),will boot and use full not lower level of graphics..this you remember,as is important,as always boot in that mode if and when recovery option is selected... So after you changed in bios,(checked that default graphic adapter is not integrated one,that default is dedicated..and then continue to boot if not boot in login scrren,reboot and boot in recovery mode..and form there continue to boot..if not boot to login screen,then reboot again and in recovery mode 1st activate networking,then go to back to same menu,chose terminal(root), check that you are connected with simple command like apt update,apt upgrade...(if you are still not connected ,i recommend to attach wired network cable,or you will need really to adjust wireless,as in further step we can download and install from terminal here amd drivers..as root..or if you can do normal boot and get that lower graphics mode,reboot maybe-most people will get full graphics mode(that without mentioned "pipe"),so solution is from booted normal mode or from recovery mode to download and install AMD drivers,or purge intel ones,or any previously used.. as those are not downloaded and installed for AMD dedicated gpu card,as in process when you was doing installation ubuntu download and install drivers for integrated card as integrated card was default primary graphics adapter...or if this all is complicated for you ,reinstall ubuntu but be sure that in bios primary graphics is dedicated(in your case AMD) not integrated(in your case INTEL).. and yes there are also other ways to install drivers,and to check what drivers are in use,and to "activate"--put in use dedicated card..but i choose this way in this answer...to familiarize you with recovery options,and terminal inside what SURE will be nice that you know..for any problem in future..as from terminal with root and with connection to internet everything can be solved.. as your dedicated graphics card is AMD for AMD (not open source)drivers check this link → http://support.amd.com/en-us/download/linux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.