I downloaded and extracted the latest Linux driver version from Realtek. I read the readme file and it instructed me to run ./autorun.sh as root. I did that. It compiled the driver for my kernel, removed the old default module, but then it fails to install the new 8168 module. It claims that it can't be found.

Can this driver be installed manually? Is there a way to fix autorun.sh so it can install properly?

  • Can you post output of the script? However, you should also ask realtek for support, they might easily know what is going on.
    – Michael K
    Commented Nov 15, 2011 at 8:08

4 Answers 4


Assuming your r8168 was compiled correctly, do the following:

  1. Create dependency list of kernel modules:

    sudo depmod -a
  2. Add this line to /etc/modprobe.d/blacklist.conf:

     blacklist r8169
  3. Edit /etc/initramfs-tools/modules and add line:

  4. Update existing initramfs:

    sudo update-initramfs -v -u -k `uname -r`

Note that in command 4, those are not quotation marks, but grave accents. That is the key to the left of the one key on the alpha part of the keyboard.

Reboot. You should come up running r8168. To verify, run

sudo lspci -v
  • Thank you for your assistance. I now have a stable connection. Your solution worked perfectly. Commented Nov 16, 2011 at 22:08
  • You are welcome. I'm glad I could help.
    – Tim
    Commented Nov 18, 2011 at 18:54

There are nice guides helping you:



But stay away from kernels newer than 3.0 ;-)


For your special problem: have you checked, if the src directory of your compilation contains a r8168.ko file? If not, the compilation failed, and I suggest you to do some adjustments as suggested here:


If the r8168.ko file has been built correctly, you just have to copy it to the /lib/modules/uname -r/kernel/drivers/net/ directory, where uname -r stands for the kernel which you compiled the module for. After that, a simple "depmod -a" and "modprobe r8168" should start the module immediately. To get it started at start-up, you have to add it to the /etc/modules file. Blacklisting r8169 in the /etc/modprobe.d/blacklist file might be necessary, but I am not sure about that.


download official driver from the following URL:


extract it and run autorun.sh file by sudo

finally reboot your system

It worked awesome for me on Fedora 35 (Linux fedora 5.16.9-200.fc35.x86_64)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .