4

Am using Ubuntu 14.04. My keyboard is acting strangely. The Mail button keeps pressing. I tried the things from the following links:

[1] How to disable keys from the keyboard?
[2] https://superuser.com/questions/775785/how-to-disable-a-keyboard-key-in-linux-ubuntu

xmodmap -e 'keycode 163='
xmodmap -e 'keycode 163=NoSymbol'
xmodmap -e 'keycode 163=0x0000'

It does prevent the key from invoking the mail application, but the key press/release events still continue (could be seen from xev). Because of this, sometimes I am not able to make mouse selections (in nautilus), and in terminal the pointer blinks very fast.

I tried cleaning the keyboard, but it was in vain. Took out the button and the reseated it, but that didn't work as well.

Can I disable the keypress for the Mail key at the lower level, so that the key press/release events does not reach the applications?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.