1

My laser printer xerox phaser 6010 doesn't work with 16.04 LTS. It is recognized and apparently accepts print jobs, but doesn't print and shows one of these messages:

waiting for print completed

or

inactive - rendering completed

It works fine with 14.04 LTS (settings seem to be the same) and Windows too.

Thanks,

Gerardo

1
  • I have exactly the same problem (via Dell 1760c) and tried the solution which worked for me under Ubuntu 14.04 and it didn't work, and also about 8 hours of other stuff and still no printing. I am sticking with Ubuntu 14.04 until I can get the printer to work (I use swoppable drives). Somewhat annoying. – Himself Nov 3 '16 at 12:51
1

I had the same problem with the 16.04.1 I installed today. I have a Xerox Phaser 6000B.

First, I tried other links saying to install cups and some libscups*:i386 packages, did not seem to help. Then, I installed gdebi. Downloaded the old recommended Debian driver from Xerox web side. Unpacked the zip file and installed that Debian driver using apt gdebi ~/Download/xxx.deb.

Then go into the normal printer from system deleted the printer, add a new printer with the 6000 driver.

Now, it works. My best guest is that it is the last step that made it work but I do not know if the first steps are needed too.

2
  • sudo apt install gdebi 2051 sudo gdebi Downloads/deb_1.01_20110210/xerox-phaser-6000-6010_1.0-1_i386. – Peter S Dec 26 '16 at 18:06
  • Uninstalled libscups2:i386, it still works. seem like using the gdebi package is the only way – Peter S Jan 3 '17 at 19:42
1

This didn't work for me, but this did- http://douglask.fog.org/home/xerox-phaser-6010n

This part was essential to get the printer working-

sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386 libcupsimage2:i386
  1. Download the .DEB driver that Xerox supplies (Here's a link for your convenience).

  2. It comes packaged as a .zip file, so extract the .zip file.

  3. Now that we have the required driver handy, we can pre-configure your system:

    sudo dpkg --add-architecture i386  
    sudo apt-get update  
    sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386 libcupsimage2:i386  
    
  4. Next, install the printer driver and any dependencies it may have. The apt-get command will install any missing dependencies and complete the installation of the driver if needed.

    cd /path/to/driver  
    sudo dpkg -i xerox-phaser-6000-6010_1.0-1_i386.deb  
    apt-get -f install  
    
  5. Now, use the printer applet in your system settings to add the printer. Ubuntu should auto-detect the printer and the driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.