0

I am new to using Ubuntu. I dual booted my HP laptop with Windows 10 and Ubuntu 16.04. I am unable to see any wireless networks on Ubuntu, but it works perfectly if I use a wired connection. My network controller is an Intel 7260 (rev 3). When I check "Software & Updates" my wireless driver does not show up. Any suggestions as to how I should proceed?

Running

lspci -nnk | grep 0280 -A2

produces the output:

09:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev c3)
DeviceName: Intel Stone Peak 2 7260 ac 2x2 + BT4 LE Combo
Subsystem: Intel Corporation Dual Band Wireless-AC 7260 [8086:c070]

Running

rfkill list all

produces the output:

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: acer-wireless: Wireless LAN
Soft blocked: yes
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Running

dmesg | grep iwl

produces

[    6.101194] iwlwifi 0000:09:00.0: Direct firmware load for iwlwifi-7260-17.ucode failed with error -2
[    6.118974] iwlwifi 0000:09:00.0: loaded firmware version 16.242414.0 op_mode iwlmvm
[    6.191797] iwlwifi 0000:09:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[    6.191938] iwlwifi 0000:09:00.0: L1 Enabled - LTR Enabled
[    6.192203] iwlwifi 0000:09:00.0: L1 Enabled - LTR Enabled
[    6.428960] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    6.430845] iwlwifi 0000:09:00.0 wlo1: renamed from wlan0
[   16.944519] iwlwifi 0000:09:00.0: L1 Enabled - LTR Enabled
[   16.944781] iwlwifi 0000:09:00.0: L1 Enabled - LTR Enabled
[   17.139952] iwlwifi 0000:09:00.0: L1 Enabled - LTR Enabled
[   17.140212] iwlwifi 0000:09:00.0: L1 Enabled - LTR Enabled
2
  • Please edit your question to add the results of these terminal commands: lspci -nnk | grep 0280 -A2 also: rfkill list all and finally: dmesg | grep iwl My money is on rfkill!
    – chili555
    Jul 1, 2016 at 20:21
  • @chili555 I have added the results of these commands. I am not entirely sure how to interpret the results. Jul 25, 2016 at 4:41

4 Answers 4

1

Run in terminal

sudo tee /etc/modprobe.d/blacklist-acer.conf <<< "blacklist acer_wmi"

and reboot.

3
  • I tried this and still no luck. However when I check rfkill list all it tells me that my Wireless LAN is now hard blocked (it wasn't before). Do I need to change this back? If so, how do i do that? Jul 26, 2016 at 1:11
  • Run sudo rfkill unblock wireless.
    – Pilot6
    Jul 26, 2016 at 7:14
  • Interesting. After running sudo rfkill unblock wireless I now have wireless access. Jul 31, 2016 at 22:00
1

Newer Kernels with hardware enablement stack should solve this however intel has drivers available here :

https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html

-1

Intel Support for Linux with Firmware updates

Click on the link above- Linux Support for Intel® Wi-Fi Adapters. You may be able to update your firmware though a link on that page. Your firmware iwlwifi may need updated

-1

Update your software. In the window that is left open after the updates notice additional tabs. Go to the Additional Drivers tab & apply changes to accept the use of proprietary drivers. You might see individual hardware drivers appear & you must check off the ones you want to use. Then click on apply changes. Go to your network connections tab. There you will be able to enable wifi. On the same tab go to edit connections. Add your SSID & password. If all fails try rebooting & run updates again. Try to connect. Good Luck!

2
  • 1
    I updated my software but there still aren't any wireless drivers in my Additional Drivers tab. Is there something I need to download manually? Jul 1, 2016 at 19:12
  • Additional Drivers only installs Broadcom drivers. It will not help his/her Intel at all.
    – chili555
    Jul 1, 2016 at 20:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .