1

I have installed Kbuntu 16.04 LTS

  • On Intel® Desktop Board DH55TC
  • With Intel® Core™ i3 CPU 540 @ 3.07GHz
  • 500 GB SATA hard drive
  • Connected to 42" LG TV with HDMI cable
  • TP-Link 300 MB USB wireless LAN
  • Wireless keyboard & mouse

All drivers are installed properly, display is also nice. All is working fine.

When I fresh install, on time zone I selected Asia and Kuwait as I am living in Kuwait (Middle East). After complete installation my desktop start showing date/time in Arabic and I cannot read Arabic so I when to System Setting --> Regional Settings --> Formats I change to United States - American English (en_US) for all options over there. So for the current session everything become English as I wanted.

Now there are two

  1. Whenever I reboot my lock screen shows me time in Arabic than after once I logged in than it will start showing in English. Even auto lock screen shows me English.So how can we change initial lock screen to English rather than Arabic
  2. Second issue, As I told initially that I am using 42" Screen, I have set my resolution to 1360x768 which works file after login but **Login screen is very wide don't show me reboot & shutdown button. And also don't show me dropdown for desktop selection
1

I had the first issue when I downloaded Kubuntu. What I had to do to fix it was to edit the /etc/default/locale file.

    :~$ cat /etc/default/locale
    #  File generated by update-locale
    LANG="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"

Edit anything that starts with ar_KW to en_US, and you will be good to go. Please remember that you require root privileges to edit this file. So, edit it using the command:

:~$ sudo nano /etc/default/locale

If you already have root privileges then:

:~# nano /etc/default/locale

You can also use any other text editor like vi, vim, gedit and so on.

As for the second issue, I am not sure what may be the cause of the problem. You may have to dive through your display settings and find what is wrong as I have never encountered this issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.