4

I don't know why but all 4 applications are not following the font size set in system settings. Any clues?

enter image description here

3

I got it. The setting that needed to be altered is found under:

System Settings> Application Style> GNOME Application Style (GTK)

enter image description here

I needed to increase the font size from 10 to 12 to match the font size i chose under:

System Settings> Font> Fonts

Here is the effect before and after:

enter image description here

Firefox is using font 10 and Opera is font 12.

1
  • Any idea where to find the equivalent setting in Xubuntu?
    – ʇsәɹoɈ
    Jul 17 '16 at 1:31
0

The issue might be with those programs themselves having a font override. I know within Firefox there are font options and sizes you can change that aren't controlled by the system unless high contrast colors are used. For Firefox it's found under Preferences> Content and going into "advanced" within that page will allow further tweaking. Not sure if it's the same for the others but I would not be surprised.

I had a similar issue but it was the tabs and menus having tiny fonts. The solution I found (for Kubuntu 16.04 anyway) was in the system settings> fonts> and at the bottom of the page is an option to "Force fonts DPI:" with an option to increase or decrease the number (default is 72 or 96). I increased mine up to 168 to get 16pt fonts to look about normal on a screen with a resolution of 2560 x 1440. Hitting "apply" and restarting applications fixed it.

1
  • The DPI solution is not acceptable to me. Yes it makes legibility a bit better but it also increases the size of the UI not just the fonts. The issue is that this behaviour. where the listed applications did not follow the system font size settings, did not exists in Kubuntu 14.04. Jul 8 '16 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.